PDA

Επιστροφή στο Forum : Cosmote Internet on the go - opensuse 11.1



geogrip
16-09-10, 00:44
καλησπερα, θα ηθελα τη βοηθεια σας για να μπορεσω να "δω" σε opensuse 11.1 το usb της cosmote internet on the go και να εχω προσβαση στο internet.
δοκιμασα το ιδιο usb σε opensuse 11.3 και δουλεψε, αλλα στο φορητο μου με 11.1 δεν το βλεπει ουτε σαν αποθηκευτικο μεσο.
ευχαριστω

arkara
16-09-10, 01:35
Δεν ξέρω γιατί δεν δουλεύει, αλλά γιατί δεν περνάς και το μικρό σε 11.3?

baskin
16-09-10, 01:45
Ευκαιρία είναι να πας σε 11.3, αλλά δώσε και ένα lsusb.

Κάβειρος
16-09-10, 01:45
Εξάλλου το 11.1 έχει τον πυρήνα 2.6.27 και το 11.3 τον 2.6.33... Άρα μάλλον είναι θέμα πυρήνα

baskin
16-09-10, 01:47
Εξάλλου το 11.1 έχει τον πυρήνα 2.6.27 και το 11.3 τον 2.6.33... Άρα μάλλον είναι θέμα πυρήνα

2.6.34 έχει το 11.3. ;)

Κάβειρος
16-09-10, 01:51
Έχεις δίκιο.. Δεν το θυμόμουν καλά:lol: Με την ευκαιρία, κάπου υπήρχε παλιά ένα αποθετήριο για vanilla kernel στο σουσε. Υπάρχει ακόμα και που;

baskin
16-09-10, 02:00
http://download.opensuse.org/repositories/Kernel:/Vanilla/

αλλά έχει μόνο για το 11.1 και το SUSE_Factory (θέλω να γίνω SLES) και νομίζω ότι δεν είναι συχνά maintained...

Κάβειρος
16-09-10, 02:18
Σε ευχαριστώ. Από το 10.3 είχαν αρχίσει να το παρατάνε νομίζω.Αλλά είμαστε :offtopic::biggrin:

geogrip
16-09-10, 08:15
βασικα ηθελα να αποφυγω τη μεταβαση σε 11,3 για λογους βαρεμαρας. οταν λεω οτι δουλεψε με 11,3 εννοω οτι ειδε το usb σα συσκευη το device notifier, και στη συνεχεια με το network manager εφτιαξα τις ρυθμισεις mobile broadband που εμφανιστηκαν.

baskin
16-09-10, 12:28
Για δώσε το lsusb.

geogrip
16-09-10, 17:39
lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 19d2:2000 ONDA Communication S.p.A.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

αυτη τη στιγμη συνδεδεμενη συσκευη usb ειναι μονο το στικακι της cosmote!

jim_p
16-09-10, 17:56
Με ενα googling ειδα οτι σαν

19d2:2000 ONDA Communication S.p.A.

αναγνωριζεται οταν ειναι στικακι και με

19d2:0016 ONDA Communication S.p.A.

σαν μοντεμ.

http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=358&sid=9a578acbbdf0016b8024b301e5cd3463

Το παραπανω γινεται με το πακετο usb-modeswitch.

geogrip
16-09-10, 18:11
το usb-modeswitch ειδα οτι ειναι κανονικα εγκατεστημενο αλλα αυτο δεν με εχει βοηθησει δυστυχως...

αυτο που σκεφτηκα τη πρωτη στιγμη που συνειδητοποιησα το προβλημα ηταν αν μπορω να εγκαταστησω μια αναβαθμισμενη εκδοση των device notifier και network manager. Ειναι αυτο εφικτο ή πρεπει να παω σε 11,3? Προσπαθω να το αποφυγω παντως, εκτος και αν ειναι η εσχατη λυση

baskin
16-09-10, 23:26
Τι KDE τρέχεις στο 11.1;

geogrip
17-09-10, 03:30
KDE 4.3.4 "release 2"

ισως φταιει αυτο

boeotian
17-09-10, 10:04
Κάνε eject το USB από τον device notifier, περίμενε κάνα λεπτό και μετά ξεκίνα τον networkmanager και ρύθμισε το 3G σου σαν κύριος.

Αν δεν κάνεις eject το usb, που να χτυπάς τογκώλο σου κάτω δεν πρόκειται να σου αναγνωρίσει ο kernel το modem. Αυτό ακριβώς έχω και εγώ και δουλεύει μια χαρά.

baskin
17-09-10, 10:38
KDE 4.3.4 "release 2"

ισως φταιει αυτο

Πάντως μπορείς να αναβαθμίσεις τον KDE στον 4.5.1 άφοβα. Το έχω κάνει στο γραφείο που είμαι και εγώ με 11.1.

geogrip
17-09-10, 11:10
Κάνε eject το USB από τον device notifier, περίμενε κάνα λεπτό και μετά ξεκίνα τον networkmanager και ρύθμισε το 3G σου σαν κύριος.

Αν δεν κάνεις eject το usb, που να χτυπάς τογκώλο σου κάτω δεν πρόκειται να σου αναγνωρίσει ο kernel το modem. Αυτό ακριβώς έχω και εγώ και δουλεύει μια χαρά.

το θεμα ειναι οτι δεν εμφανιζεται στο device notifier το στικακι:(

jim_p
17-09-10, 11:28
Παιξτο αλλιως τοτε. Βγαλτο, κανε rmmod στο usb-storage και μετα βαλτο.

budha
17-09-10, 13:37
Μήπως πρέπει να αναβαθμίσεις τους udev rules του usb_modeswitch?

citakis
17-09-10, 13:40
Έχω χρόνια να χρησιμοποιήσω το opensuse αλλά η λύση που χρησιμοποιώ σε ubuntu πρέπει να κάνει και για σένα. Δοκίμασε το sakis3g (http://www.sakis3g.org/). Έμένα μου έχει λύσει τα χέρια ακόμα και με τα πιο δύστροπα modem.

geogrip
17-09-10, 15:16
οχι, δυστυχως, μολις το δοκιμασα και μου λεει οτι δεν μπορει να συνδεθει με το modem

πρεπει να θελει καποιον νεοτερο kernel προφανως για να δει τη συσκευη και αν δεν υπαρχει λυση με νεο kernel στο 11.1 τοτε παμε για εγκατασταση του 11.3.......

baskin
17-09-10, 16:17
Αν είναι να πας σε νέο kernel κάνε την αβαρία και βάλε 11.3 να τελειώνεις.

geogrip
17-09-10, 16:37
μαλλον κατα κει παει το πραμμα...

boeotian
18-09-10, 16:32
το θεμα ειναι οτι δεν εμφανιζεται στο device notifier το στικακι:(

Τότε λυπάμαι πολύ δεν αναγνωρίζεται καθόλου. Κάνε το upgrade σου και τα ξαναλέμε :)

budha
18-09-10, 19:13
Κάνε eject το USB από τον device notifier, περίμενε κάνα λεπτό και μετά ξεκίνα τον networkmanager και ρύθμισε το 3G σου σαν κύριος.

Αν δεν κάνεις eject το usb, που να χτυπάς τογκώλο σου κάτω δεν πρόκειται να σου αναγνωρίσει ο kernel το modem. Αυτό ακριβώς έχω και εγώ και δουλεύει μια χαρά.

Έχω την εντύπωση οτι το network manager χρησιμοποιεί το usb_modeswitch. Το θέμα με το unplug και το "περίμενε κάνα λεπτό πριν το κάνεις plug" ήταν γνωστό bug μέχρι και την 1.1.3 version του usb_modeswitch. Είναι διορθωμένο στην 1.1.4 και δεν χρειάζεται το unplug/plug.

geogrip
18-09-10, 19:52
τελικα αναγκαστηκα να περασω σε opensuse11.3 για να δουλεψει. Δε χρειαζεται να κανεις τιποτε αλλο περα απο το πρωτο σεταρισμα. μετα απο αυτο απλα το συνδεεις και ξεμπερδεψες!

baskin
18-09-10, 20:38
τελικα αναγκαστηκα να περασω σε opensuse11.3 για να δουλεψει. Δε χρειαζεται να κανεις τιποτε αλλο περα απο το πρωτο σεταρισμα. μετα απο αυτο απλα το συνδεεις και ξεμπερδεψες!

Σιγά που σε χάλασε!!!! :p

geogrip
19-09-10, 01:09
οκ, δε με χαλασε, αλλα εφαγα καποια ωρα...

geogrip
28-10-10, 11:16
λοιπον επιστρεφω γιατι υπαρχει παλι προβλημα. δοκιμαζω να συνδεθω συμφωνα με τα παραπανω. Αποσυνδεω το stick απο το device notifier, περιμενω, και επιλεγω να συνδεθω. Εμφανιζεται ενδειξη "activating" αλλα αμεσως μετα σταματαει. Εχω τσεκαρει pin και puk και ολα τα αλλα στις ρυθμισεις ειναι οπως πριν αλλα δε θελει να συνδεθει με τιποτα

Caret
28-10-10, 14:54
Εγώ με ένα stick της Cosmote χρησιμοποιούσα αυτό (http://www.sakis3g.org/).

geogrip
28-10-10, 17:52
και πως το χρησιμοποιω αυτο?

Caret
28-10-10, 17:57
Kατεβάζεις το έτοιμο εκτελέσιμο, πάς σε κονσόλα και δίνεις

$ sh sakis3g

Σε κάποια φάση θα σου ζητήσει και password για root.

geogrip
28-10-10, 18:12
δε μου δουλεψε, εχω usb-modeswsicth και ppp αλλα δεν

geogrip
28-10-10, 23:59
μπορουμε να κανουμε κατι απο κονσολα για να δουμε που κολλαει μηπως και το φτιαξουμε?

baskin
29-10-10, 00:07
λοιπον επιστρεφω γιατι υπαρχει παλι προβλημα. δοκιμαζω να συνδεθω συμφωνα με τα παραπανω. Αποσυνδεω το stick απο το device notifier, περιμενω, και επιλεγω να συνδεθω. Εμφανιζεται ενδειξη "activating" αλλα αμεσως μετα σταματαει. Εχω τσεκαρει pin και puk και ολα τα αλλα στις ρυθμισεις ειναι οπως πριν αλλα δε θελει να συνδεθει με τιποτα

Αν δεν το αποσυνδέσεις τι κάνει;

geogrip
29-10-10, 00:37
ξεκιναει με "activating" για 3 δευτερολεπτα και σταματαει. Το ιδιο κανει και οταν ειναι αποσυνδεδεμενο πριν.
Σα να προσπαθει να συνδεθει αλλα δε μπορει

........Auto merged post: geogrip πρόσθεσε 22 λεπτά και 13 δευτερόλεπτα αργότερα ........

παρατηρησα τα εξης που αναγραφονται οταν ακνει προσπαθεια συνδεσης

type: Mobile Broadband
interface: ttyUSB2
driver: option1
status: preparing to connect
ip:
name servers:
domains:

baskin
29-10-10, 00:43
Στο /var/log/messages βλέπεις τίποτα; (δεν έχω δουλέψει ποτέ με τέτοια συσκευή και δεν έχω ιδέα).

geogrip
29-10-10, 01:23
και το messages αλλα και το NetworkManager ειναι κενα

........Auto merged post: geogrip πρόσθεσε 37 λεπτά και 25 δευτερόλεπτα αργότερα ........

ψαχνω να βρω τροπο να "δω" απο τη κονσολα τυχον προβλημα αλλα δε τα καταφερνω. Γινεται να προσπαθησω τη συνδεση απο κονσολα?

geogrip
29-10-10, 13:41
λυθηκε το προβλημα ως εξης
εκανα εγκατασταση το stick πρωτα σε windows και μετα σε περιβαλλον linux συνδεθηκε κανονικα

Copyright © Keen Notion Co (2002-2014) Copyright Keen Notion Co.