PDA

Επιστροφή στο Forum : Packet tracer και frame relay



nstamoul
03-01-10, 16:18
Καλησπέρα.Διαβάζω για το ICND2 και δοκιμάζω κάποια πράγματα στο packet tracer.Έχω κάνει μια διάταξη που δουλεύει εν μέρει και δεν μπορώ με τίποτα να βρω το λάθος.Το πρόβλημα είναι ότι δουλεύει μόνο το λινκ ανάμεσα σε R0 και R,δλδ κάνουν ping και γίνονται και eigrp neighbors.Με τα άλλα 2 με δεν κάνει τπτ από τα 2. Αν κάποιος έχει όρεξη ας ρίξει μια ματιά μπας και βρει κάτι.Επισυνάπτω διαγράμματα και configurations.

Router0:

Router#show run
Router#show running-config
Building configuration...

Current configuration : 870 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 51
!
interface Serial0/0.2 point-to-point
ip address 192.168.2.1 255.255.255.0
frame-relay interface-dlci 52
!
interface Serial0/0.3 point-to-point
ip address 192.168.3.1 255.255.255.0
frame-relay interface-dlci 53
!
router eigrp 1
network 192.168.1.0
network 192.168.10.0
network 192.168.2.0
network 192.168.3.0
auto-summary
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Router1:

Router#show running-config
Building configuration...

Current configuration : 558 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.11.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 50
!
router eigrp 1
network 192.168.11.0
network 192.168.1.0
auto-summary
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end


Router2:

Router#show running-config
Building configuration...

Current configuration : 558 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.2.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 50
!
router eigrp 1
network 192.168.12.0
network 192.168.2.0
auto-summary
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end


Router3:

Router#show running-config
Building configuration...

Current configuration : 558 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.13.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.3.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 50
!
router eigrp 1
network 192.168.3.0
network 192.168.13.0
auto-summary
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

lacacitos
04-01-10, 00:59
Από packet tracer δεν ξέρω τίποτα, αλλά μου φαίνεται ότι είναι λίγο μπερδεμένα τα DLCI. Έχεις δοκιμάσει να μην αλλάζεις το DLCI δηλ. ο κάθε router R1,R2,R3 να τερματίζει τα DLCI 51,52,53 αντίστοιχα?

nstamoul
04-01-10, 02:39
Ειναι hub and spoke διάταξη με κεντρικό site το R1 και χρησιμοποιώ global addressing,γιαυτό είναι έτσι τα DLCI.

lacacitos
04-01-10, 10:25
οκ, στο debug frame lmi πχ στον r2 (κάπως έτσι είναι η εντολή) βλέπεις να έρχεται τίποτα?

taxiarxos
04-01-10, 11:09
Καλημέρα κ Χρόνια Πολλά..

Ποιά version του Packet Tracer έχεις; Έχεις την τελευταία;

Γενικός έχει μερικά bug το packet tracer κ σε κάποια δοκιμαστικά που είχα κάνει δεν μου δούλευαν παλιότερα.

Τώρα από όσο ξέρω εφόσον έχεις hub n spoke δίκτυο λογικά τα περνάς όλα από τον κεντρικό σου Router, δοκίμασε να βάλεις ένα acl στο eigrp κ επίσης δήλωσε κ passive int.


ελπίζω να βοήθησα good luck.

karavagos
04-01-10, 11:35
Κάτι γρήγορο που είδα : άλλαξε το 192.168.3.1 του R3 σε .2
ping από τον R0 στους υπόλοιπους κάνεις?

nstamoul
05-01-10, 03:02
Ping κάνει μόνο από R0 σε R1.Και φυσικά διορθώθηκε και η ΙΡ του R3.

Το debug frame-relay lmi σε R2 και R3 δεν βγάζει τίποτα οπότε υποθέτω πως είναι bug ή "feature" :p του packet tracer και ως εκ' τούτου παραιτούμαι.Έτσι και αλλιώς για εξάσκηση ήταν,δεν ήταν real world.

Ευχαριστώ όσους ασχολήθηκαν :)

karavagos
05-01-10, 03:39
Δώσε και μερικά "sh frame pvc" και "sh frame map" (σε όλους τους routers) αν δεν έχεις παραιτηθεί ακόμα.

nstamoul
05-01-10, 13:08
I never quit ;)

R0:


Router#show frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)
DLCI = 51, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

DLCI = 52, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.2

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

DLCI = 53, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.3

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

Router#
Router#show frame-relay map
Serial0/0.1 (up): point-to-point dlci, dlci 51, broadcast, status defined, active
Serial0/0.2 (up): point-to-point dlci, dlci 52, broadcast, status defined, active
Serial0/0.3 (up): point-to-point dlci, dlci 53, broadcast, status defined, active

R1:


Router#show frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)
DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

Router#show frame-relay map
Router#

R2:


Router#show frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DCE)
DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

Router#show frame-relay map
Router#

R3:


Router#show frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DCE)
DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155

Router#show frame-relay map
Router#

Και ένα debug από το R3:

Router#debug frame-relay lmi
Frame Relay LMI debugging is on
Displaying all Frame Relay LMI data
Router#
Serial0/0(out): StEnq, myseq 1, yourseen 0, DTE up
datagramstart = 0xE7829994, datagramsize = 13
FR encap = 0x00010308
00 75 51 01 00 53 02 01 00

karavagos
05-01-10, 23:38
Επειδή το serial interface (και γενικά όλα τα φυσικά interfaces) θεωρείται by default multipoint, χρειάζεται να δηλώσεις στατικά τα frame-relay mappings στους R1,R2,R3.

π.χ. για τον R1


interface Serial0/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.1 50 broadcast
no frame-relay interface-dlci 50 ! αυτό δεν χρειάζεται αν βάλεις static mapping


ή να ετοιμάσεις και σε αυτούς point-to-point subinterfaces και να μεταφέρεις εκεί το ip, όπως στον R0.

nstamoul
06-01-10, 11:48
Το δοκίμασα.Τίποτα :hmm:

karavagos
06-01-10, 13:47
Δώσε ξανά το config των serial interfaces και "sh frame map".

nstamoul
06-01-10, 21:04
Από το R2:

Router#show interfaces Serial 0/0.2
Serial0/0.2 is up, line protocol is down (disabled)
Hardware is HD64570
Internet address is 192.168.2.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY
Last clearing of "show interface" counters never
Router#
Router#
Router#show frame-relay map
Router#

Επισυνάπτω ολόκληρο το "project" για packet tracer 5.2

karavagos
06-01-10, 21:53
Από το output φαίνεται ότι μάλλον δεν έχεις προσθέσει το "frame-relay interface-dlci 50" στο s0/0.2.

Επίσης δοκίμασε να ρυθμίσεις το clock rate (σε οποιαδήποτε τιμή) στα serial interfaces των routers (εκεί που βλέπεις down το line protocol). Οι (si/e)mulators έχουν κάποιο θέμα με το clocking (αν και το συγκεκριμένο μάλλον είναι bug).

Τελικά είδα ότι έχεις χρησιμοποιήσει λάθος καλώδιο στους R2 & R3. Πρέπει να έχεις το clocking από την πλευρά του frame relay switch.

nstamoul
06-01-10, 23:55
:respekt:

Δεν μου πήγε καθόλου το μυαλό εκεί μιας και το λινκ το έκανα με το "αυτόματο".Χίλια ευχαριστώ.

@ ADSLgr.com All rights reserved.