PDA

Επιστροφή στο Forum : Βοήθεια για port forward



stamp81
24-06-10, 19:06
Καλησπέρα σε όλους!.

Μια βοήθεια παρακαλώ για ένα cisco870.
Όλα δουλεύουν το internet κτλ έχω ανοίξει και το port 27015 για να το counter strike και μπαίνει ο φίλος μου κανονικά στον server που σήκωσα στο 1 pc που έχω local.
To πρόβλημα είναι ότι ενώ ο φίλος μου μπαίνει κανονικά από το σπίτι του, δεν μπορώ να μπω από το άλλο pc που έχω local.
Πατάει ο φίλος μου connect στο ip που μου δίνει ο isp π.χ. 90.90.90.10:27015
και συνδέεται, ενώ όταν κάνω και εγώ στην ίδια ip από το άλλο pc που είναι local δεν συνδέεται.
Τα δύο pc συνδέονται σε ένα switch και μετά στο cisco στο port που βρίσκεται το Vlan1. Και τα δυο συνδέονται κανονικά στο internet.
Παραθέτω και το config.




Building configuration...

Current configuration : 7698 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
clock timezone PCTime 2
clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 4:00
!
crypto pki trustpoint TP-self-signed-2683487998
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2683487998
revocation-check none
rsakeypair TP-self-signed-2683487998
!
!
crypto pki certificate chain TP-self-signed-2683487998
certificate self-signed 01
3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32363833 34383739 3938301E 170D3130 30363231 32333531
33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 36383334
38373939 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100BC9F 2F1F18D2 4CF2A34B D9A79F80 2DDAAA10 1E49206E 01D91757 5F6BFAD4
5AF18A79 93651BE1 65452DA5 5DC486E4 2AE52C85 0F368EDF F34BA86B 91715527
A06EFAFE 992FE84E 6BD11D39 25008011 A6F198B6 B1D83F6A 7C5FD3E3 D298251A
5FAD9932 D34E61D3 F067FDA4 90BBFA52 E3732DC1 0F68D41B 936207DF 6052EAD3
B7E10203 010001A3 74307230 0F060355 1D130101 FF040530 030101FF 301F0603
551D1104 18301682 14696361 66652E79 6F757264 6F6D6169 6E2E636F 6D301F06
03551D23 04183016 801464E5 B52C8F42 FF18E63A 7CDE4F58 6EA8061B 0CA2301D
0603551D 0E041604 1464E5B5 2C8F42FF 18E63A7C DE4F586E A8061B0C A2300D06
092A8648 86F70D01 01040500 03818100 B484EA7F 0EC9183A D07E69C7 C32E1C66
13641BB3 F0AFF7E0 0D7A48FB 45B41B79 C622C2F2 9E550761 98B4F14E 284427FD
1C520922 695F5A34 CCB8DFCA 1EF27068 3EBCD977 EB67B9DA EC0610A1 87EE0110
DD9FA3BD 8B30DC4E 317C0CEA E386D9E4 49E7FBB1 BA55CBAA 92FA367A ACF8FE5F
7D8A9DF8 6C52C1E7 F479EDB7 D4D5E7A0
quit
dot11 syslog
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
import all
network 10.10.10.0 255.255.255.248
default-router 10.10.10.1
dns-server 195.170.2.2 195.170.0.1
lease 0 2
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain name yourdomain.com
ip name-server 195.170.2.2
ip name-server 195.170.0.1
!
!
!
!
username ******* privilege 15 secret 5 ********************.
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.248
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ********
ppp chap password 0 ******
ppp pap sent-username ****** password 0 ********
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface Dialer0 overload
ip nat inside source static tcp 10.10.10.2 27015 interface Dialer0 27015
ip nat inside source static udp 10.10.10.2 27015 interface Dialer0 27015
!
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 10.10.10.0 0.0.0.7 any
no cdp run
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege level of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.

username <myuser> privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use.

For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
login local
transport input ssh
!
scheduler max-task-time 5000
end

gatoulas
24-06-10, 20:46
Εσύ θα χρησιμοποιήσεις την 10.10.10.2:27015

stamp81
24-06-10, 21:18
Σε ευχαριστώ για την απάντηση φίλε.

Ναι το δοκίμασα έτσι και δουλεύει.
Απλώς και στο παιχνίδι warcraft 3 το οποίο χρησιμοποιεί τα port 6112-6119.
Τα άνοιξα μεν τα port, hostarei το pc το game και λέμε στο φίλο μας να μπει στο game με όνομα π.χ. warcraft3 gogo.
Μπορεί και μπαίνει το παιδί στο game αλλά στο άλλο pc που είναι local όταν πατάει να μπει στο game με όνομα warcraft3 gogo του λέει δεν υπάρχει και τρώει πόρτα :(
Τι στο καλό μπορεί να συμβαίνει.

taxiarxos
25-06-10, 19:25
Μήπως είναι πρόβλημα του παιχνιδιού κ όχι του router;:hmm:

stamp81
25-06-10, 19:54
Δοκίμασα και το αντίστροφο να hostaro από το άλλο pc που είναι local αλλά το αποτέλεσμα είναι το ίδιο. Έχω βγάλει όλα τα firewall έχω πειράξει access_list κλπ αλλά τίποτα. Σκέτη σπαζοκεφαλιά έχει καταντήσει.

stamp81
26-06-10, 14:03
Έχω ψάξει στο internet και βρήκα παρόμοια προβλήματα


https://supportforums.cisco.com/thread/218643?decorator=print&displayFullThread=true
http://www.velocityreviews.com/forums/t39455-cannot-access-my-web-server-from-within-my-lan.html

αλλά πουθενά δεν είδα αν κάποιος βρήκε λύση σε αυτό το πρόβλημα.
Δοκίμασα ένα παλιό speedtouch και δουλεύει κανονικά είτε κάνω connect με την local ip είτε με τιν ip του isp.

Γνωρίζει μήπως κάποιος κανένα τρόπο που μπορεί να γίνει π.χ. nat, vpn, loopback, bidirectional

MAO TAO
27-06-10, 19:00
αν θέλεις να συνδέεται το pc σου που είναι πίσω από τον Ρουτερ πρέπει να του "μάθεις" την ιντερνέτ ονομασία που εξυπηρετείς από τον σερβερ.

δηλαδή με λίγα λόγια αν έχεις ένα dyndns.org σαν και αυτό warcraft.dyndns.org στον server με local ip 192.168.1.100 γραφείς στο hosts αρχείο στο pc που θες να συνδεθει

192.168.1.100 warcraft.dyndns.org

Έτσι δεν θα ψάχνει έξω από τον Ρουτερ τον σερβερ.

Αν επιπλέον έχεις ρυθμίσει και vpn ανάλογα ρυθμίζεις και να συνδέεται το pc στο vpn network.

stamp81
27-06-10, 20:44
Ευχαριστώ φίλε για την απάντηση.

Το δοκίμασα και με αυτόν τον τρόπο αλλά δυστυχώς δουλεύει μόνο για το εσωτερικό του δικτύου και όχι για έξω.

Το πρόβλημα είναι όταν ξεκινάει το σήμα από το pc και φτάνει μέχρι ip isp, αντί να ξανά γυρίσει τα πακέτα πίσω στα local pc τα κάνει drop και δυστυχώς πολλά router δεν διαθέτουν αυτήν την λειτουργία (NAT loopback). Υπάρχουν όμως πολλά forum που έχουν κάνει λίστα με ποια router υποστηρίζουν NAT loopback και ένα από αυτά είναι και το speedtouch 585v6 (είναι αυτόματα ενεργοποιημένο) το οποίο έχω στα χέρια μου και το εμφανίζει στο config του ως:

[ ip.ini ]
config natloopback=enabled

Στην περίπτωση του Cisco 870 series απ’ότι βρήκα υπάρχει τρόπος να γίνει αλλά δυστυχώς φαίνεται πως κανένας δεν κατάφερε να το κάνει καθώς χρειάζεται config από πολύ έμπειρους χρήστες.

taxiarxos
28-06-10, 12:33
Σε ποιόν πάροχο είσαι;

stamp81
28-06-10, 13:24
Στον ΟΤΕ φίλε μου...αλλά το δοκίμασα και σε HOL.

@ ADSLgr.com All rights reserved.