PDA

Επιστροφή στο Forum : Cisco877 & 16 Public IP



gtsoukas
09-11-10, 00:37
Καλησπέρα σας.
Απ' οτι γνωρίζω όταν ο πάροχος σου δώσει μία 16αδα Public IPs θα πρέπει να απενεργοποιήσης το ΝΑΤ και να δώσεις στο εσωτερικό σου δίκτυο τις Public Address.

To ερώτημα μου είναι το εξης :
Βάση της 16αδας λογικά μόνο 14 PCs μπορώ να έχω στο δίκτυο μου , υπάρχει άλλος τροπος να βάλω όλα τα pc μου και να δουλεψω πάλι τα NAT (Μέσω του Cisco φυσικά ;)
Ένα Configuration Example Θα με βοηθούσε(Γνωρίζω απο CLI)
Ευχαριστώ!!!

SfH
09-11-10, 10:01
Δε σε περιορίζει κανένας στο τι ακριβώς θα κάνεις nat. Μπορείς σε όσα pc θες να δώσεις πραγματικές διευθύνσεις ( είτε απευθείας ή με nat ), σε όσα pc θες να κάνεις overload στην ip του dialer, ή ακόμα και να κάνεις overload σε μερικές από τις 16 διευθύνσεις που έχεις ανάλογα με τις ανάγκες σου.

gtsoukas
09-11-10, 12:02
Σε ευχαριστώ για την απάντηση.
Δηλαδή αντι να δώσω στον dialer ip address negotiated , μπορώ να βάλω τις ip/mask Και να παίξω κανονικά με nat overload ;.Το ρωτώ αυτο γιατί o Dialer εκτος απο την 16αδα παίρνει και αυτός μια άλλη IP.

binary_dreamer
09-11-10, 12:13
Μπορείς να κάνεις πολλά πράγματα.
μια εκδοχή είναι να συνεχίσεις όπως έκανες ΝΑΤ μέχρι τώρα και να δηλώσεις κάποιον υπολογιστή να έχει απευθείας μια στατική ΙΡ (static NAT).
Μια άλλη λύση είναι να κάνεις ΝΑΤ όπως έκανες για οποιονδήποτε υπολογιστή και μετά να πάρεις ένα pool από IPs και να τους κάνεις ΝΑΤ σε μια συγκεκριμμένη ΙΡ και πάει λέγοντας.

SfH
09-11-10, 12:14
Όχι, ο dialer θα πάρει την ip που πρέπει να πάρει. Τις 16 δεν τις "παίρνει" ο dialer, απλά δρομολογούνται προς αυτόν. Μπορείς να τις βάλεις σε ένα/πολλά ip pools ή ακόμα και να βάλεις static nat entries. Γενικά έχεις αρκετές επιλογές.

Το ερώτημα είναι τι ακριβώς θες να κάνεις και τι ανάγκες έχεις.

gtsoukas
09-11-10, 12:26
ΟΚ μάλλον κατάλαβα.εγώ για την ακρίβεια έχω αυτές 79.129.90.208/28 και εξωτερικη 79.129.61.174.
Θα κάνω Configuration τον Dialer όπως πάντα και στην γραμμή του NAT (πχ για τον Mail Server mou ) θα γράψω
ip nat outside source static 79.129.90.210 192.168.2.10.

arisgr
09-11-10, 12:36
Και παρεπιπτοντος, εχεις 16 public IPs για 16 PCs κα οχι 14

gtsoukas
09-11-10, 12:38
Και παρεπιπτοντος, εχεις 16 public IPs για 16 PCs κα οχι 14

router & broadcast ;

wasntme
15-11-10, 01:59
13 IP tha exei gia ta PCs tou Netaddres+Broadcast+IP panw ston Fa0/0 tou router gia GW.

Hit. to fa interface pernei entolh secondary gia private ips sou. An den bgaleis akri pes mou na sou sthlw to config example.

gtsoukas
15-11-10, 09:40
Σας ευχαριστώ πολύ για τις απαντήσεις σας και για τον χρόνο που διαθέσατε.
έπιασα το γενικό πλάνο για το πώς να το κάνω!.

arisgr
15-11-10, 12:56
13 IP tha exei gia ta PCs tou Netaddres+Broadcast+IP panw ston Fa0/0 tou router gia GW.

Hit. to fa interface pernei entolh secondary gia private ips sou. An den bgaleis akri pes mou na sou sthlw to config example.

Η περιπτωση που αναφερεις δεν χρησιμοποιει NAT.

wasntme
15-11-10, 23:47
Η περιπτωση που αναφερεις δεν χρησιμοποιει NAT.

RTFM - Real man do it on keayboard only.

ΝΑΤ will be enabled on the FA0/0 for the private ips as secondary where real one will be primary.

I have a working config of Public and private ips working together where private use NAT/PAT, but for you I have my doubts. So please take the following advice it's free of charge for now "Better to keep your mouth shut and be thought a fool than to open it and remove all doubt".

SfH
15-11-10, 23:50
RTFM.

ΝΑΤ will be enabled on the FA0/0 for the private ips.
Αυτό που θέλει να πει ο arisgr μάλλον είναι ότι μπορείς αντί να δώσεις το subnet μέσα, να κάνεις nat χωρίς overload ( static matches ή ip pooling ) και να χρησιμοποιήσεις και τις 16 .

wasntme
16-11-10, 00:03
Αυτό που θέλει να πει ο arisgr μάλλον είναι ότι μπορείς αντί να δώσεις το subnet μέσα, να κάνεις nat χωρίς overload ( static matches ή ip pooling ) και να χρησιμοποιήσεις και τις 16 .

yep right It's not a bug, it's a feature.

arisgr
16-11-10, 14:32
Να'σαι καλά ρε wasntme, με'κανες και γέλασα :rofl:
Φυσικά και έτσι όπως λες, επίσης γίνεται, αυτό δεν σημαίνει οτι είναι η καλύτερη επιλογή για τον φίλο.
Και παρεμπίπτοντος, δεν είναι κακό να μιλάς ελληνικά. Ακομα τουλαχιστον είναι η επίσημη γλώσσα του κράτους.

wasntme
17-11-10, 11:10
interface Ethernet0
ip address 192.168.10.200 255.255.255.0 secondary
ip address 212.XXX.3.233 255.255.255.XXX
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip route-cache flow
no cdp enable
!
ip nat pool lan2gw 212.XXX.3.233 212.XXX.3.233 netmask 255.255.255.XXX
ip nat inside source list 111 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 111 permit ip 192.168.10.0 0.0.0.255 any
dialer-list 1 protocol ip permit

μακάρι οι πτωχοί τω πνευματι
Και όμως είναι η καλύτερη επιλογή από όλες τις απόψεις. Δεν θα μπω σε λεπτομερές να τεκμηριώσω την άποψη μου σε εσένα.

Υ.Γ.: Η ηλιθιότητα είναι χειρότερη από την αγνεία.
Υ.Γ.2: Έχεις δίκαιο η ελληνική γλωσσά είναι (ακόμη) επίσημη γλωσσά στην μπανανιά.


Να'σαι καλά ρε wasntme, με'κανες και γέλασα :rofl:
Φυσικά και έτσι όπως λες, επίσης γίνεται, αυτό δεν σημαίνει οτι είναι η καλύτερη επιλογή για τον φίλο.
Και παρεμπίπτοντος, δεν είναι κακό να μιλάς ελληνικά. Ακομα τουλαχιστον είναι η επίσημη γλώσσα του κράτους.

arisgr
17-11-10, 12:37
Δεν θα σου ζητησω να την τεκμητιωσεις διοτι σιγουρα δεν μπορεις.
Και ειναι λογικο να μην μπορεις, μιας και δεν εχεις ασχοληθει να μαθεις για τις αναγκες του συγκεκριμενου δικτυου. Απευθειας παρουσιαζεις τις secondary IPs σαν την καλυτερη λυση.
Απο εκει και περα, το πιθανοτερο ειναι ο φιλος να κανει static NAT καποιες διευθυνσεις για τους server του και αυτο ειναι ολο!
Και για να μην ξεχνιομαστε, κρατωντας το ετσι απλο, ΜΠΟΡΕΙ να εχει μεχρι και 16 static NAT + overload

wasntme
17-11-10, 12:53
Και γιατί να μην κάνει assign κατευθείαν από Real IP Range στους Servers?
Κρατώντας το NAT μονό για τους clients?

Δεν θα σου ζητησω να την τεκμητιωσεις διοτι σιγουρα δεν μπορεις.
Και ειναι λογικο να μην μπορεις, μιας και δεν εχεις ασχοληθει να μαθεις για τις αναγκες του συγκεκριμενου δικτυου. Απευθειας παρουσιαζεις τις secondary IPs σαν την καλυτερη λυση.
Απο εκει και περα, το πιθανοτερο ειναι ο φιλος να κανει static NAT καποιες διευθυνσεις για τους server του και αυτο ειναι ολο!
Και για να μην ξεχνιομαστε, κρατωντας το ετσι απλο, ΜΠΟΡΕΙ να εχει μεχρι και 16 static NAT + overload

arisgr
17-11-10, 13:41
οκ μπαινουμε σε μια συζητηση στην οποια δεν υπαρχει συμπερασμα για τον απλο λογο οτι το τι θα επιλεξεις εξαρταται απο πολλους παραγοντες σχεδιασης.
Ενας απλος λογος που μου ερχεται ειναι οτι ετσι θα παει χαμενη μια public IP (για τη fe) που εχεις αγορασει.
Επισης, θεωρειται best practice η αποφυγη των secondary IPs οπου ειναι δυνατο.
Κανενα routing protocol δεν τα παει καλα με αυτες :)

arisgr
11-12-10, 15:55
Εχοντας ψαξει λιγο περισσοτερο το θεμα, θα ηθελα να ρωτησω τον wasntme ή οποιον αλλον γνωριζει, ΓΙΑΤΙ ειναι καλυτερα να βαλεις στο παιχνιδι secondary IPs και να μπλεξεις private με public.
Ισως μαθω κατι καινουγιο που δεν ηξερα.

@ ADSLgr.com All rights reserved.