PDA

Επιστροφή στο Forum : Load Sharing - Πάρα πολύ αργό δίκτυο



d.stathopoulos
12-05-14, 23:30
Κατάφερα να configurάρω Load Sharing με cef σε 2 ΙSP γραμμές.
Χρειάζομαι την βοήθειά σας γιατί όλα τα requests προς τα έξω(e.g browsing), ακόμη και τα DNS requests είναι πολύ αργά:



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname routina-ph-rc1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone EET 2
clock summer-time EEST recurring last Sun Mar 3:00 last Sun Oct 4:00
!
!
dot11 syslog
no ip source-route
!
!
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool generic
network 192.168.0.0 255.255.255.0
dns-server 195.170.0.1 195.170.2.2
default-router 192.168.0.1
!
!
ip cef
ip cef load-sharing algorithm include-ports source destination
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
vtp mode transparent
username xxx privilege 15 secret 5 xxx
!
!
!
archive
log config
hidekeys
!
!
!
track 1 interface Dialer0 line-protocol
!
track 2 interface Dialer1 line-protocol
!
!
!
interface FastEthernet0/0
ip address 192.168.168.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
pvc 8/35
pppoe-client dial-pool-number 2
!
!
interface Dialer0
description "----- INTERNET 1 -----"
ip address negotiated
no ip proxy-arp
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp authentication chap callin
ppp chap hostname xx
ppp chap password 7 xxx
!
interface Dialer1
description "----- INTERNET 2 -----"
ip address negotiated
no ip proxy-arp
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 2
no cdp enable
ppp authentication pap callin
ppp pap sent-username abc@otenet.gr password 7 xxx
!
router eigrp 50
redistribute static
network 192.16.168.0 0.0.0.3
network 192.168.168.0 0.0.0.3
auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 track 2
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map ADSL0 interface Dialer0 overload
ip nat inside source route-map ADSL1 interface Dialer1 overload
!
access-list 11 permit 192.168.0.0 0.0.0.255
access-list 12 permit 192.168.168.0 0.0.0.3
access-list 14 permit 10.224.244.0 0.0.0.255
!
!
!
!
route-map ADSL0 permit 10
match ip address 11 or 12 or 14
match interface Dialer0
!
route-map ADSL1 permit 10
match ip address 11 or 12 or 14
match interface Dialer1
!
!
!
control-plane
!
!
!
line con 0
line aux 0
login local
line vty 0 4
login local
!
scheduler allocate 20000 1000
end


οποιαδήποτε βοήθεια θα ήταν κάτι παραπάνω από ευπρόσδεκτη!

SfH
15-05-14, 10:06
Όπως έχω αναφέρει εδώ (http://www.adslgr.com/forum/threads/757044-Cisco-1841-2-ADSL-2-ISP-Load-Balance-per-Session?p=5172923&viewfull=1#post5172923), υπάρχουν θεματάκια με αυτό το setup. Για αρχή, ξέχνα τους dns των παρόχων. Βάλε κάποιον γνωστό dns που απαντάει recursive queries από παντού ( google, opendns, κτλ ). Αφού το κάνεις αυτό, δες τι προβλήματα παραμένουν.

d.stathopoulos
15-05-14, 22:50
@SfH

Ευχαριστώ πάρα πολύ για την υπερπολύτιμη βοήθειά σου και τις πολύ σημαντικές πληροφορίες.
1) Έκανα αυτό που είπες (δηλαδή recursive DNS) και η ταχύτητα resolving αυξήθηκε.
2) Για το πρόβλημα των appls του ανοίγουν πολλαπλά connections / ή web-banking σκέφτομαι να φτιάξω κατάλληλες access lists και route maps για να βγαίνουν από συγκεκριμένο interface.

@ ADSLgr.com All rights reserved.