PDA

Επιστροφή στο Forum : Cisco 2821 με 1ο aDSL interface και Cisco 876 με 2ο aDSL interface



nisiotisr
26-07-14, 22:16
Παιδιά καλησπέρα σας. Έχω εδώ και μια εβδομάδα που προσπαθώ να λύσω το παρακάτω πρόβλημα με το setup του δικτύου μου. Έχω έναν 2821 για voice gateway και ένα 876 για internet access. Ο voice gateway συνδέεται και με ένα ip phone μέσω tunnel σε ένα απομακρυσμένο χώρο. (με τον 876 να έχει το tunnel). Πρόσφατα έβαλα μια ακόμα adsl γραμμή και την έχω πάνω σε ένα ZTE του ΟΤΕ. Την γραμμή αυτή την χρησιμοποιώ για το ασύρματο δίκτυο των πελατών (έχω ορίσει τα VLAN στον 2821 για τα 2 δίκτυα και αυτός δίνει τα IP - DHCP για κάθε δίκτυο). Έχω το ZTE για gateway του δικτύου των πελατών και μέχρι εδώ όλα παίζουν μια χαρά. Θέλω να καταργήσω το ZTE και να βάλω το aDSL στον 2821 (σε μια κάρτα HWIC). Όλα μια χαρά και με αυτό το setup με τη μόνη διαφορά ότι στον 2821 όταν ορίζω τα routes στο Dialer0 χάνω το tunnel και δεν παίζει το απομακρυσμένο ip phone. Όταν ορίζω και τα 2 routes σε
ip route 0.0.0.0 0.0.0.0 192.168.0.253 (192.168.0.253 είναι ο 876 για το δικό μου adsl με το remote ip phone)
ip route 0.0.0.0 0.0.0.0 Dialer0
δεν παίζει τίποτα (ούτε WLAN ούτε ip phone)
δοκίμασα και με route-map αλλά μάλλον δεν έχω καταλάβει την λειτουργία τους. Παρακάτω έχω τα config των 2821 - 876 που παίζει με το ZTE. Δεν θέλω να κάνω κάποιο load balancing - θέλω τα 2 δίκτυα να είναι αυτόνομα προς το παρών. Καμία ιδέα; Ευχαριστώ

Cisco 2821 config

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec localtime
service password-encryption
!
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
no logging console
!
aaa new-model
!
!
aaa authentication login default local
aaa accounting connection h323 start-stop group radius
!
!
aaa session-id common
clock timezone Athens 2
clock summer-time Athens recurring
network-clock-participate wic 1
!
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.253
ip dhcp excluded-address 192.168.4.253
ip dhcp excluded-address 192.168.4.254
!
ip dhcp pool ITS
network 192.168.0.0 255.255.255.0
default-router 192.168.0.253
dns-server 195.170.0.1
option 150 ip 192.168.0.1
lease 0 0 30
!
ip dhcp pool WLAN
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1
dns-server 195.170.0.1
lease 0 0 30
!
!
ip domain name tivoli.local
multilink bundle-name authenticated
!
isdn switch-type basic-net3
!
!
voice translation-rule 10
rule 1 /^0/ //
!
!
voice translation-profile profile10
translate called 10
!
!
voice-card 0
no dspfarm
!
!
application
service camp-on flash:alarm.tcl
paramspace english index 1
paramspace english language en
paramspace english location flash:/alarm/
!
!
!

!
!

!
!
!
spanning-tree backbonefast

archive
log config
hidekeys
!
!
gw-accounting syslog
!
!
!
!
interface GigabitEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$FW_INSIDE$$ETH-LAN$
no ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.0.1 255.255.255.0
!
interface GigabitEthernet0/0.3
description wireless
encapsulation dot1Q 3
ip address 192.168.4.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/1
description $FW_INSIDE$$ETH-LAN$
ip address 192.168.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface BRI0/1/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn static-tei 0
!
interface BRI0/1/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn static-tei 0
!
interface ATM0/3/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/3/0.1 point-to-point
description ClientsWAN
no snmp trap link-status
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxx
ppp chap password xxx
!
ip route 0.0.0.0 0.0.0.0 192.168.0.253
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 102 interface GigabitEthernet0/1 overload
!
logging 192.168.1.10

access-list 102 permit ip 192.168.0.0 0.0.0.255 any
access-list 103 permit ip 192.168.1.0 0.0.0.255 any
access-list 104 permit ip 192.168.2.0 0.0.0.255 any
access-list 105 permit ip 192.168.4.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
...



aDSL 876 config

version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
no logging console

!
no aaa new-model
clock timezone Athens 2
clock summer-time Athens recurring
!

!
!

no ip source-route
ip dhcp excluded-address 10.10.10.1
!
!
ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip bootp server
ip domain name tivoli.local
ip name-server 195.170.0.2
!
!
!

!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface Tunnel0
ip address 10.1.1.1 255.255.255.248
tunnel source Dialer0
tunnel destination 85.22.182.206
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $FW_OUTSIDE$$ES_WAN$
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
no cdp enable
!
interface FastEthernet1
no cdp enable
!
interface FastEthernet2
no cdp enable
!
interface FastEthernet3
no cdp enable
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0 secondary
ip address 192.168.0.253 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxx
ppp chap password xxx
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.2.0 255.255.255.0 Tunnel0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload

!
no logging trap
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
...

SfH
27-07-14, 11:53
Η θα κάνεις policy-based routing ( και policy-based NAT ), ή θα χρησιμοποιήσεις VRFs. Στη δεύτερη λύση, έχεις και το extra ότι τα δίκτυα του wireless θα είναι απομονωμένα από τα εσωτερικά σου δίκτυα ( αν το θες, αν δεν το θες θα μπορούσες να κάνεις επιλεκτικά leak routes ).

nisiotisr
27-07-14, 12:21
Η θα κάνεις policy-based routing ( και policy-based NAT ), ή θα χρησιμοποιήσεις VRFs. Στη δεύτερη λύση, έχεις και το extra ότι τα δίκτυα του wireless θα είναι απομονωμένα από τα εσωτερικά σου δίκτυα ( αν το θες, αν δεν το θες θα μπορούσες να κάνεις επιλεκτικά leak routes ).

με policy-based routing δοκίμασα αλλά μάλλον τα έκανα λάθος, και δεν δούλεψε... όσο για το VRF φοβάμαι ότι θα τα κάνω χειρότερα...
υπάρχει κάποιο παράδειγμα που μπορώ να βρω, με policy based routing; κάτι είδα μέσα στο forum εδώ (http://www.adslgr.com/forum/threads/376657-CISCO-2811-one-ethernet-2-adsl-(wan)-lines) αλλά θέλω σε επίπεδο IP και όχι πρωτοκόλλου. Μπορεί να κάνω και λάθος...

ευχαριστώ

SfH
27-07-14, 16:13
Θα φτιάξεις 2 route-maps . Στο ένα θα κάνεις match μια acl που θα πιάνει τα source δίκτυα που θες να έχουν διαφορετική δρομολόγηση ( π.χ. , του ασυρμάτου ) και θα κάνει set interface τον dialer. Στο δεύτερο θα κάνεις πάλι match την ίδια acl και τον dialer . Ο πρώτος route-map θα μπει σαν ip policy στο interface που θες να επηρεάσεις ( υποθέτω το subint του ασυρμάτου ) και ο δεύτερος θα μπει στο nat statement για τον dialer.

@ ADSLgr.com All rights reserved.