PDA

Επιστροφή στο Forum : Cisco 837 και Windows Server 2003 All In One



wintech2003
04-09-04, 20:28
Λοιπον έχουμε σετάρει εναν server με Windows 2003 Enterprise Edition, περάσαμε όλα τα hotfixes και του εγκαταστήσαμε

τα ακόλουθα:

- Active Directory
- DNS
- DHCP
- IIS6 (για http και ftp)
- Exchange Server 2003 Enterprise

Ο υπολογιστής αυτός έχει 1 κάρτα δικτυου και την IP 192.168.1.1

Επίσης έχουμε εναν Cisco 837 (192.168.1.254) και μια σύνδεση ADSL με 8 static ip's (οι 6 usuables).

Θέλουμε μια λύση All in One (γνωρίζοντας τις επιπτώσεις) για HTTP/FTP/DNS/OWA/MAIL services.

Το δίκτυο των static ips από τον ISP είναι: 213.5.x.120 255.255.255.248

Αυτό που θέλουμε είναι:

Να κατοχυρώσουμε τις IP 213.5.x.121 και 213.5.x.122 ως nameservers για το domain mydomain.gr (αυτό το κάνει ο registar οπότε δεν ασχολούμαστε με αυτό)
Άρα θέλουμε οι δυο αυτές IP να κάνουν forward τα DNS (Port 53?) queries στον 192.168.1.1

Μετά θέλουμε η IP 213.5.x.123 να κάνει forward στον 192.168.1.1 ότι έχει σχέση με port 80 (www)
Αντίστοιχα η IP 213.5.x.124 να κάνει forward την port 21 για FTP και η 213.5.x.125 να ειναι το mail.mydomain.gr (Port 110)

Τέλος θέλουμε στην 213.5.x.123 (www.mydomain.gr) να υπάρχει η δυνατότητα το 213.5.x.123:8080 να πηγαινει στο /exchange του IIS6 ώστε αν κάποιος δώσει http://www.mydomain.gr:8080 να τον κανει redirect στο OWA (Outlook Web Access) Login Page.

To IOS που χρησιμοποιώ είναι το c837-k9o3y6-mz.123-8.T3.bin

Το config του router ειναι το εξής:



!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxxxxxxxxx
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret xxxxxxxxxx
!
username xxxxxxxxxx password xxxxxxxxxx
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
!
!
ip name-server 213.5.41.8
ip name-server 213.5.17.21
ip inspect name myfw cuseeme timeout 3600
ip inspect name myfw ftp timeout 3600
ip inspect name myfw rcmd timeout 3600
ip inspect name myfw realaudio timeout 3600
ip inspect name myfw smtp timeout 3600
ip inspect name myfw tftp timeout 30
ip inspect name myfw udp timeout 15
ip inspect name myfw tcp timeout 3600
ip inspect name myfw h323 timeout 3600
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip mroute-cache
hold-queue 100 out
!
interface ATM0
no ip address
no ip mroute-cache
atm vc-per-vp 64
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip access-group 111 in
ip nat outside
ip inspect myfw out
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxx
ppp chap password xxxxxxxxxx
ppp pap sent-username xxxxxxxxxx password xxxxxxxxxx
hold-queue 224 in
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static udp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static tcp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static udp 192.168.1.2 4672 interface Dialer1 4672
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer1 4662
ip nat inside source static upd 192.168.1.1 53 213.5.x.121 53
ip nat inside source static upd 192.168.1.1 53 213.5.x.122 53
ip nat inside source static tcp 192.168.1.1 80 213.5.x.123 80
ip nat inside source static tcp 192.168.1.1 8080 213.5.x.123 8080
ip nat inside source static tcp 192.168.1.1 21 213.5.x.124 21
ip nat inside source static tcp 192.168.1.1 110 213.5.x.125 110
!
!
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 111 permit tcp any any eq pop3
access-list 111 permit tcp any any eq ftp
access-list 111 permit tcp any any eq www
access-list 111 permit tcp any any eq 8080
access-list 111 permit tcp any any eq 4662
access-list 111 permit udp any any eq 4672
access-list 111 permit tcp any any eq 1412
access-list 111 permit udp any any eq 1412
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit udp any eq bootps any eq bootpc
access-list 111 permit udp any eq bootps any eq bootps
access-list 111 permit udp any eq domain any
access-list 111 permit esp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit udp any any eq 10000
access-list 111 permit tcp any any eq 1723
access-list 111 permit tcp any any eq 139
access-list 111 permit udp any any eq netbios-ns
access-list 111 permit udp any any eq netbios-dgm
access-list 111 permit gre any any
access-list 111 deny ip any any
dialer-list 1 protocol ip permit
snmp-server community xxxxxxx RO
snmp-server enable traps tty
!
control-plane
!
!
line con 0
exec-timeout 120 0
modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
login local
modem InOut
modem autoconfigure discovery
transport preferred all
transport input all
transport output all
speed 9600
flowcontrol hardware
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
length 0
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
end


Αυτό που με ενδιαφέρει ειναι τι λάθος υπάρχει στο configuration (δεν μπορει.. κάμια μικρή λεπτομέρια είναι) που δεν με αφήνει να κάνω τίποτα απο αυτά που θέλω... :)

Μην μου πείτε τίποτα ακόμα σχετικά με τo DNS (δεν ειναι σεταρισμένα τα aliases), για την ώρα θέλω απλά μέσω των IP να συνδέομαι.

Firewall δεν ειναι ενεργοποιημένο στα Windows 2003 και πέρα απο το ADSL Router δεν υπάρχει τίποτα άλλο.

Any help?

Τί μου διαφέυγει?

Ευχαριστώ,
Γιώργος

chatasos
04-09-04, 22:13
Ούτε το dynamic nat (απλά πρόσβαση από ένα pc προς το internet) δουλεύει?

Ένα "access-list 111 deny ip any any log" θα βοηθούσε σε 1η φάση στο troubleshooting.

Όπως και ένα "sh ip nat trans" και ένα "debug ip nat" βοηθάνε σε τέτοιες καταστάσεις, μαζί με ένα "debug ip packet detail" την ώρα του υπάρχει traffic.

Επίσης για δοκίμασε "sh ip route 213.5.x.120 255.255.255.248" και μετά να δηλώσεις μία ip από το 213.5.x.120 255.255.255.248 σαν secondary στο eth0...

wintech2003
04-09-04, 23:08
Το απλό dynamic nat λειτουργεί κανονικα. Απο μεσα προς τα έξω πάνε όλα μια χαρα (και αντιστροφα παιζει.. π.χ. το emule παιρνει κανονικα high id).

Θα κάνω τα υπόλοιπα που γράφεις και θα σου πω.

NetTraptor
05-09-04, 02:05
Για κάνε μια δοκιμή και βάλε αυτά το access list 111 πριν τα deny σου


access-list 111 permit udp any host interface Dialer1 eq 1412
access-list 111 permit tcp any host interface Dialer1 eq 1412
access-list 111 permit udp any host interface Dialer1 eq 4672
access-list 111 permit tcp any host interface Dialer1 eq 4662
access-list 111 permit upd any host 213.5.x.121 eq 53
access-list 111 permit upd any host 213.5.x.122 eq 53
access-list 111 permit tcp any host 213.5.x.123 eq 80
access-list 111 permit tcp any host 213.5.x.123 eq 8080
access-list 111 permit tcp any host 213.5.x.124 eq 21
access-list 111 permit tcp any host 213.5.x.125 eq 110

Επίσης κάτι που δεν μου αρέσει είναι ότι ξοδεύεις πολλές IP για πράγματα τα οποία μπορείς να τα κάνεις με 2.
Καταλαβαίνω ότι την δεύτερη την θέλεις γιατί πρέπει να την έχεις για τους DNS. ΟΙ άλλες όμως πάνε στράφι αφού μιλάμε για το ίδιο μηχάνημα.
Απλά στο πορτ 21 ftp στο 8080 Webmail στο ….. Με ένα IP. Τωρα αν θελεις στο ιδιο public IP να έχεις 2 Host names αυτό γίνετε είτε με alias records είτε με ένα δεύτερο Host A record το οποίο να δείχνει στο ίδιο IP.
Πχ www.wintech2003.gr και mx1.wintech2003.gr αλλά και mail.wintech2003.gr να είναι στην ουσία το ίδιο IP.

Επίσης


ip nat pool myIPpool 213.5.x.121 213.5.x.126 netmask 255.255.255.248
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static udp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static tcp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static udp 192.168.1.2 4672 interface Dialer1 4672
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer1 4662
ip nat inside source static upd 192.168.1.1 53 213.5.x.121 53
ip nat inside source static upd 192.168.1.1 53 213.5.x.122 53
ip nat inside source static tcp 192.168.1.1 80 213.5.x.123 80
ip nat inside source static tcp 192.168.1.1 8080 213.5.x.123 8080
ip nat inside source static tcp 192.168.1.1 21 213.5.x.124 21
ip nat inside source static tcp 192.168.1.1 110 213.5.x.125 110


Για πάμε με αυτά για αρχή και βλέπουμε… Παπαπα σιχαίνομαι το IOS. Πάει καιρός που δεν το έχω κάνει αυτό το CLI debugging. Αλλά για σένα χαλάλι…

Επίσης τα παρακάτω PAT δεν μου αρέσουν... είναι πολύ specific αλλά μπορεί και να παίζουν..
Δοκίμασε IP to IP πρώτα σαν το παράδειγμα 1




ip nat inside source static udp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static tcp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static udp 192.168.1.2 4672 interface Dialer1 4672
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer1 4662
ip nat inside source static upd 192.168.1.1 53 213.5.x.121 53
ip nat inside source static upd 192.168.1.1 53 213.5.x.122 53
ip nat inside source static tcp 192.168.1.1 80 213.5.x.123 80
ip nat inside source static tcp 192.168.1.1 8080 213.5.x.123 8080
ip nat inside source static tcp 192.168.1.1 21 213.5.x.124 21
ip nat inside source static tcp 192.168.1.1 110 213.5.x.125 110

παράδειγμα 1
ip nat inside source static 192.168.1.1 213.5.x.121


Παρακάτω μετά με τα rules του Firewall ορίζεις ποια port και πρωτόκολλα θέλεις να είναι ανοιχτά. Όπως στο πρώτο Quote

NetTraptor
05-09-04, 02:18
Για παρτο έτσι μάλλον θα παίζει καλύτερα… ??? Cross fingers. Πες μου αν δουλέψει..


!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no ip http secure-server
ip nat pool myIPpool 213.5.x.121 213.5.x.126 netmask 255.255.255.248
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static 192.168.1.2 interface Dialer1
ip nat inside source static 192.168.1.1 213.5.x.121
ip nat inside source static 192.168.1.1 213.5.x.122
ip nat inside source static 192.168.1.1 213.5.x.123
ip nat inside source static 192.168.1.1 213.5.x.124
ip nat inside source static 192.168.1.1 213.5.x.125
!
!
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 111 permit udp any host interface Dialer1 eq 1412
access-list 111 permit tcp any host interface Dialer1 eq 1412
access-list 111 permit udp any host interface Dialer1 eq 4672
access-list 111 permit tcp any host interface Dialer1 eq 4662
access-list 111 permit upd any host 213.5.x.121 eq 53
access-list 111 permit upd any host 213.5.x.122 eq 53
access-list 111 permit tcp any host 213.5.x.123 eq 80
access-list 111 permit tcp any host 213.5.x.123 eq 8080
access-list 111 permit tcp any host 213.5.x.124 eq 21
access-list 111 permit tcp any host 213.5.x.125 eq 110
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit udp any eq bootps any eq bootpc
access-list 111 permit udp any eq bootps any eq bootps
access-list 111 permit udp any eq domain any
access-list 111 permit esp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit udp any any eq 10000
access-list 111 permit tcp any any eq 1723
access-list 111 permit tcp any any eq 139
access-list 111 permit udp any any eq netbios-ns
access-list 111 permit udp any any eq netbios-dgm
access-list 111 permit gre any any
access-list 111 deny ip any any
dialer-list 1 protocol ip permit
snmp-server community xxxxxxx RO
snmp-server enable traps tty
!

wintech2003
05-09-04, 13:04
Επίσης κάτι που δεν μου αρέσει είναι ότι ξοδεύεις πολλές IP για πράγματα τα οποία μπορείς να τα κάνεις με 2.
Καταλαβαίνω ότι την δεύτερη την θέλεις γιατί πρέπει να την έχεις για τους DNS. ΟΙ άλλες όμως πάνε στράφι αφού μιλάμε για το ίδιο μηχάνημα.
Απλά στο πορτ 21 ftp στο 8080 Webmail στο ….. Με ένα IP. Τωρα αν θελεις στο ιδιο public IP να έχεις 2 Host names αυτό γίνετε είτε με alias records είτε με ένα δεύτερο Host A record το οποίο να δείχνει στο ίδιο IP.
Πχ www.wintech2003.gr και mx1.wintech2003.gr αλλά και mail.wintech2003.gr να είναι στην ουσία το ίδιο IP.


Έχεις δίκιο σε αυτό. Τελικά τα έβαλα όλα στην .121 και μονο το secondary DNS στην .122

Breaking News: Λειτουργει! :)
Τελικα πήγα στο CRWS, άνοιξα τα ports με το PAT, και απλά πήγα και άλλαξα όπου Dialer0 την static ip.

Και έπαιξε.

Αν και νομιζω οτι και πριν κανω Post το πρώτο thread έπαιζε, απλά έφταιγε που χρησιμοποιούσα για την δοκιμή PC που πήγαινε πάνω στο Router.
Το δοκίμασα με το Laptop από μια Dialup και παίζει μια χαρα :)
Κάτι προβληματάκια στο Passive Mode FTP έχω αλλα θα τα βρώ και αυτά :)

Τhnx for the help!

wintech2003
05-09-04, 13:26
Έπαιξε και το passive mode.

Άρα ειμαστε κομπλε τώρα.

Παμε για domain registration και κατοχυρωση nameserver.

Και μετά είναι η ώρα για τον DNS Server :)

wintech2003
05-09-04, 15:45
Πέρα απο την UDP 53 πρέπει να κάνω και κάτι άλλο forward για να παίξει ο DNS?

Στο εσωτερικό δίκτυο παιζει κανονικα ο DNS:

> server 192.168.1.1
Default Server: [192.168.1.1]
Address: 192.168.1.1

> set type=ANY
> xxx.gr
Server: [192.168.1.1]
Address: 192.168.1.1

xxx.gr nameserver = proteus.xxx.gr
xxx.gr
primary name server = proteus.xxx.gr
responsible mail addr = hostmaster.xxx.gr
serial = 3
refresh = 900 (15 mins)
retry = 600 (10 mins)
expire = 86400 (1 day)
default TTL = 3600 (1 hour)
proteus.xxx.gr internet address = 192.168.1.1

Οταν όμως κάνω το ίδιο και απο το laptop με server 213.5.x.121 (όποιος μπορει να βοηθήσει ας στείλει ενα pm να του πώ το x) μου βγάζει DNS request timed out.
Άρα ή κάτι μπλοκάρει την udp 53 ή χρειάζεται και κάποια άλλη port για να κανεις reverse lookup.

Το config με το οποιο παιζουν όλα μέχρι στιγμης ειναι:




!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco837.xxx.gr
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret xxxxxxxx
!
username Router password xxxxxxxxxxx
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
!
!
ip name-server 213.5.x.121
ip name-server 213.5.x.122
ip inspect name myfw cuseeme timeout 3600
ip inspect name myfw ftp timeout 3600
ip inspect name myfw rcmd timeout 3600
ip inspect name myfw realaudio timeout 3600
ip inspect name myfw smtp timeout 3600
ip inspect name myfw tftp timeout 30
ip inspect name myfw udp timeout 15
ip inspect name myfw tcp timeout 3600
ip inspect name myfw h323 timeout 3600
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip mroute-cache
hold-queue 100 out
!
interface ATM0
no ip address
no ip mroute-cache
atm vc-per-vp 64
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip access-group 111 in
ip nat outside
ip inspect myfw out
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxx
ppp chap password xxxxxxxxx
ppp pap sent-username xxxxxxxxx password xxxxxxxxxx
hold-queue 224 in
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer1 4662
ip nat inside source static udp 192.168.1.2 4672 interface Dialer1 4672
ip nat inside source static tcp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static udp 192.168.1.2 1412 interface Dialer1 1412
ip nat inside source static tcp 192.168.1.1 80 213.5.x.121 80
ip nat inside source static tcp 192.168.1.1 21 213.5.x.121 21
ip nat inside source static tcp 192.168.1.1 53 213.5.x.121 53
ip nat inside source static tcp 192.168.1.1 53 213.5.x.122 53
ip nat inside source static udp 192.168.1.1 53 213.5.x.121 53
ip nat inside source static udp 192.168.1.1 53 213.5.x.122 53
ip nat inside source static tcp 192.168.1.1 110 213.5.x.121 110
ip nat inside source static tcp 192.168.1.1 5500 213.5.x.121 5500
ip nat inside source static tcp 192.168.1.1 5501 213.5.x.121 5501
ip nat inside source static tcp 192.168.1.1 5502 213.5.x.121 5502
ip nat inside source static tcp 192.168.1.1 5503 213.5.x.121 5503
ip nat inside source static tcp 192.168.1.1 5504 213.5.x.121 5504
ip nat inside source static tcp 192.168.1.1 5505 213.5.x.121 5505
ip nat inside source static tcp 192.168.1.1 5506 213.5.x.121 5506
ip nat inside source static tcp 192.168.1.1 5507 213.5.x.121 5507
ip nat inside source static tcp 192.168.1.1 5508 213.5.x.121 5508
ip nat inside source static tcp 192.168.1.1 5509 213.5.x.121 5509
ip nat inside source static tcp 192.168.1.1 5510 213.5.x.121 5510
!
!
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit udp any any eq 53
access-list 111 permit tcp any any eq smtp
access-list 111 permit tcp any any eq 53
access-list 111 permit tcp any any range 5500 5600
access-list 111 permit tcp any any eq pop3
access-list 111 permit tcp any any eq ftp
access-list 111 permit tcp any any eq www
access-list 111 permit udp any any eq 1412
access-list 111 permit tcp any any eq 1412
access-list 111 permit udp any any eq 4672
access-list 111 permit tcp any any eq 4662
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit udp any eq bootps any eq bootpc
access-list 111 permit udp any eq bootps any eq bootps
access-list 111 permit udp any eq domain any
access-list 111 permit esp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit udp any any eq 10000
access-list 111 permit tcp any any eq 1723
access-list 111 permit tcp any any eq 139
access-list 111 permit udp any any eq netbios-ns
access-list 111 permit udp any any eq netbios-dgm
access-list 111 permit gre any any
access-list 111 deny ip any any
dialer-list 1 protocol ip permit
snmp-server community Router837 RO
snmp-server enable traps tty
!
control-plane
!
!
line con 0
exec-timeout 120 0
no modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
speed 1200
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
length 0
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
end


Μήπως παίζει κάτι με τα ip inspect name myfw?

NetTraptor
05-09-04, 16:08
Αν και νομιζω οτι και πριν κανω Post το πρώτο thread έπαιζε, απλά έφταιγε που χρησιμοποιούσα για την δοκιμή PC που πήγαινε πάνω στο Router.
Το δοκίμασα με το Laptop από μια Dialup και παίζει μια χαρα :)


Αν σου πω ότι το φαντάστηκα θα με πιστέψεις….
Την έχω πατήσει πολλές φορές όχι τόσο χοντρά αλλά στο περίπου.
Πχ μια φορά είχα 2 net connections πάνω στο εσωτερικό νετ με translations στο ίδιο subnet 192.168.0.0 και ενώ προσπαθούσα να βγω από την μια και να μπω από την άλλη δεν γινότανε. Όταν τα 2 router είναι ενωμένα φυσικά από μέσα μάλλον παίζει δικτυακό βραχυκύκλωμα πακέτων. Εκτός αν κάποιος μπορεί να βοηθήσει εδώ και λέω Μ@λ@κιες.
Πάντως μια dialup και με ένα laptop είναι πάντα εγγύηση για τέτοιου είδους τσεκαρίσματα.
Τα παραπάνω που σου έγραψα πρέπει 90% να παίζουν αν και είναι λίγο μίξερ μεταξύ των δικών μου και αυτών που θέλεις εσύ. Πάντως το config σου άμα παίζει έχει μερικά ενδιαφέροντα σημεία τα οποία θα αναγκαστώ να καταγράψω για μερικές βρομοδουλειές που θέλω να κάνω.

Τελικά δεν κατάλαβα το πρώτο που έστειλες έπαιζε?? ή Έπαιξε με αυτά που σου έστειλα? Κάποια PAT για το μουλάρι και για αλλά p2p φαίνεται να είναι χρήσιμα + το ότι τα περίεργα PAT που έλεγα στην αρχή μπορεί να είναι ποιο secure από αυτά που σου έγραψα. Αν παίζουν και τα 2 εγώ θα προτιμούσα τα δικά σου.

NetTraptor
05-09-04, 16:32
Πάρε και αυτό έχει όλα τα ports για το Server System…

NetTraptor
05-09-04, 16:38
Για πρόσθεσε και αυτό να δούμε…
access-list 111 permit udp any any eq 53

NetTraptor
05-09-04, 16:40
access-list 102 permit udp any any eq 53 Ναι ρε να η πατάτα

111 όχι 102

wintech2003
05-09-04, 17:38
Αυτό υπάρχει ήδη, ειναι ουσιαστικά το:

access-list 111 permit udp any any eq netbios-ns

το άλλο με το 102 ήταν μια δοκιμή να δώ μηπως η γραμμή

ip nat inside source list 102 interface Dialer1 overload

παιζει κανενα ρόλο στο outgoing traffic.

NetTraptor
06-09-04, 01:01
Όταν τον ανοίξετε αύριο στείλε ένα pm.. προσπαθώ να το δω και τπτ

wintech2003
08-09-04, 01:10
Αδέλφια μου τελικά ειμαι πανηλίθιος!

Το πρόβλημα δεν ήταν στο router αλλά στον DNS Server, στον οποίο είχα φτιάξει reverse lookup zones μονο για το 192.168.1.x.
Τελικά με το που έφτιαξα και για το ip range των στατικών μου IP, έπαιξε με την μια!

Μηχανήματα του σατανα :) :) :) :) :)

@ ADSLgr.com All rights reserved.