Αναζήτηση:

Type: Posts; Χρήστης: tvangel; Λέξη(εις) Κλειδιά:

Αναζήτηση: Η αναζήτηση ολοκληρώθηκε σε 0,02 δευτερόλεπτα

  1. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Αρα θες σιγουρα NAT για αυτο που δεν εχεις.

    το ΝΑΤ εχει οριστει (?):

    add action=masquerade chain=srcnat disabled=no out-interface=WAN2
  2. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Αυτο που αναφερεις ειναι απο τη μερια που μας εδειξες το configuration. Εγω μιλαω για την απεναντι μερια. Η "συσκευη" 10.2.60.59 σε /24 δικτυο πρεπει να εχει gateway μια ΙΡ 10.2.60.x το οποιο θα κανει το routing προς το αλλο σημειο.

    Η IP ειναι public (web site). Δηλαδη αν τη χτυπησει καποιος σε ενα browser ανοιγει μια σελιδα. Αυτο που θελω ειναι οταν καποιος ζηταει αυτη τη συγκεκριμενη IP, αυτος να δρομολογειται απο το συγκεκριμενο gateway (10.1.1.138)
  3. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Μια συσκευη με ΙΡ 10.2.60.59/24 δεν ειναι δυνατον να εχει gateway το 10.1.1.138

    Οταν το destination ip ειναι το 10.2.60.59 τοτε δρομολογησε απο το GW 10.1.1.138. Αυτος ειναι ο σκοπος
  4. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Η δρομολογηση γινεται σωστα. Το 10.2.60.59 εχει το σωστο gateway;

    Ναι, το GW ειναι το 10.1.1.138

    - - - Updated - - -

    Απο wiki προτεινουν το ιδιο που σου εγραψα και εγω................


    In fact, the bare bones way to do it is without connection marks and with just route marking, e.g.:
    Code: Select all
    /ip firewall mangle
    add chain=prerouting src-address=192.168.0.1/16 action=mark-routing new-routing-mark=to_ISP1
    add chain=prerouting src-address=10.0.1.1/24 action=mark-routing new-routing-mark=to_ISP2
    But the first approach with connection marks is more future proof. For example, if you decided to forward some port from ISP1's address to 10.0.1.x (i.e. host that normally uses ISP2), it would just work with connection marking. But it would fail with this other approach.

    macro θα μπορουσες να γραψεις τους κανονες που λες για το συγκεκριμενο config?
  5. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Μπορεις να κανεις ενα traceroute και να μας το δειξεις;

    205061

    Δεν φτανει ποτε στο GW (10.1.1.138) και συνεχιζει επ'αοριστον με timeouts
  6. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Αν βαλεις ολο το subnet με /24 παιζουν ολα?

    Εννοεις το destination IP να ειναι 10.2.60.0/24? Το εχω δοκιμασει, ουτε ετσι παιζει
  7. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Καλημερα,

    Ναι, στο ιδιο interface εχω δυο IPs (WANs). Η 10.1.1.138 ειναι η gateway του εν λογω WAN. To αλλο WAN εχει gateway την 10.30.52.1 και οτι routes βαζω προς εκει, παιζει κανονικα
  8. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Απάντηση: Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Καλημερα,

    Δεν το καταλαβα αυτο που εγραψες. Δεν χρειαζεται καποιο entry στο ip/route, μονο στο mangle?
  9. Μηνύματα
    18
    Εμφανίσεις
    1.618

    Πρόβλημα με δρομολόγηση μέσω συγκεκριμένου WAN

    Καλημερα σε ολους τους RouterOS gurus!

    Παιδια εχω το εξης προβλημα. Εχω το παρακατω configuration (working):


    /ip address
    add address=10.24.14.1/23 disabled=no interface=LAN network=10.24.14.0
    add address=10.4.14.2/24 disabled=no interface=WAN1 network=10.4.14.0
    add address=10.30.52.242/24 disabled=no interface=WAN2 network=10.30.52.0
    add address=10.1.1.2/24 disabled=no interface=WAN2 network=10.1.1.0

    /ip firewall filter
    add action=accept chain=input disabled=no dst-address=10.30.52.242 dst-port=\
    8080 in-interface=WAN2 protocol=tcp
    add action=accept chain=output disabled=no out-interface=WAN2 protocol=tcp \
    src-address=10.24.14.21 src-port=8080

    /ip firewall mangle
    add action=mark-connection chain=prerouting disabled=no in-interface=WAN1 \
    new-connection-mark=WAN1_connection passthrough=yes
    add action=mark-connection chain=prerouting disabled=no in-interface=WAN2 \
    new-connection-mark=WAN2_connection passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=WAN1_connection \
    disabled=no in-interface=LAN new-routing-mark=to_WAN1 passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=WAN2_connection \
    disabled=no in-interface=LAN new-routing-mark=to_WAN2 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN2_connection \
    disabled=no new-routing-mark=to_WAN2 passthrough=yes

    /ip firewall nat
    add action=masquerade chain=srcnat disabled=no src-address=10.24.14.0/23
    add action=masquerade chain=srcnat disabled=no out-interface=WAN2
    add action=masquerade chain=srcnat disabled=no out-interface=WAN1
    add action=dst-nat chain=dstnat disabled=no dst-address=10.30.52.242 \
    dst-port=8080 in-interface=WAN1 protocol=tcp to-addresses=10.24.14.21 \
    to-ports=8080
    add action=dst-nat chain=dstnat disabled=no dst-address=10.30.52.242 \
    dst-port=8080 in-interface=WAN2 protocol=tcp to-addresses=10.24.14.21 \
    to-ports=8080

    /ip route
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.30.52.1 \
    routing-mark=to_WAN2 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.4.14.1 scope=30 \
    target-scope=10
    add disabled=no distance=1 dst-address=10.2.60.59/32 gateway=10.1.1.138 \
    scope=30 target-scope=10
    add comment=ROUTE1 disabled=no distance=1 dst-address=10.50.14.0/24 gateway=\
    10.30.52.1 scope=30 target-scope=10
    add comment=ROUTE2 disabled=no distance=1 dst-address=10.50.14.80/32 \
    gateway=10.30.52.1 scope=30 target-scope=10
    add comment=ROUTE3 disabled=no distance=1 dst-address=10.50.147.11/32 \
    gateway=10.30.52.1 scope=30 target-scope=10
    add comment=ROUTE4 disabled=no distance=1 dst-address=10.50.147.16/32 \
    gateway=10.30.52.1 scope=30 target-scope=10
    add comment=ROUTE5 disabled=no distance=1 dst-address=10.19.25.0/24 \
    gateway=10.30.52.1 scope=30 target-scope=10
    add comment=ROUTE6 disabled=no distance=1 dst-address=84.225.251.238/32 \
    gateway=10.30.52.1 scope=30 target-scope=10


    Οταν προσπαθω στο ip/route να βαλω την εξης γραμμη:
    add disabled=no distance=1 dst-address=10.2.60.59/32 gateway=10.1.1.138 \
    scope=30 target-scope=10
    δεν δρομολογειται προς το συγκεκριμενο gateway.
    Μηπως μπορειτε να με βοηθησετε να εντοπισω το προβλημα?

    Ευχαριστω προκαταβολικα!
Εμφάνιση 1-9 από 9