Εμφάνιση 1-15 από 15
  1. #1
    Εγγραφή
    11-03-2024
    Μηνύματα
    5
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    Καλησπέρα παιδιά,

    Έβαλα πρόσφατα οπτική ίνα (NOKIA ONT + Speedport Plus 2).

    Προσπάθω να σετάρω ένα δικό μου router που τρέχει OPNsense προκειμένου να στήσω την εξής συνδεσμολογία: ONT -> OPNsense -> Speedport (μόνο για τηλεφωνία).

    Έχω πάρει PPPoE κωδικούς από COSMOTE, έχω το VLAN ID (835), και έχω δοκιμάσει τα πάντα.

    Δεν ξέρω τι κάνω λάθος...

    Ένα καλό guide που βρήκα είναι αυτό: https://forum.opnsense.org/index.php?topic=21207.0

    αλλά παρόλο που το ακολούθησα κατά γράμμα δεν κατάφερα να συνδεθώ...

    Μπορεί κάποιος που έχει καταφέρει κάτι αντίστοιχο να βοηθήσει;

  2. #2
    Εγγραφή
    12-06-2011
    Μηνύματα
    8.371
    Downloads
    4
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    500/50 + 250/80
    ISP
    Ote/Vodafone
    Router
    Pf plus/nokia - mu5001 5G
    Οσο δεν ποσταρεις logs και config screens τι θες να πουμε?

    ΥΓ Αν εβαζες και pfsense even better .

  3. #3
    Εγγραφή
    09-02-2006
    Μηνύματα
    3.072
    Downloads
    4
    Uploads
    0
    Τύπος
    VDSL2
    ISP
    ΟΤΕ Conn-x
    Router
    OPNsense
    Στο opnsense, πήγαινε Interfaces > point to point > log file και δες αν υπάρχει κάποιο warning ή error.

    Επισης αν βάλεις το speedport απευθείας στο ONT χωρις το opnsense έχεις Ίντερνετ;

  4. #4
    Εγγραφή
    11-03-2024
    Μηνύματα
    5
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    Παράθεση Αρχικό μήνυμα από netblues Εμφάνιση μηνυμάτων
    Οσο δεν ποσταρεις logs και config screens τι θες να πουμε?

    ΥΓ Αν εβαζες και pfsense even better .
    Δεν έχεις και άδικο

    Παραθέτω από κάτω screenshots από το configuration των interfaces και logs...

    Interfaces Menu
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Interfaces Menu.png 
Εμφανίσεις:  15 
Μέγεθος:  21,7 KB 
ID: 254917


    LAN Interface
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  LAN.png 
Εμφανίσεις:  20 
Μέγεθος:  258,0 KB 
ID: 254918


    WAN Interface
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  WAN.png 
Εμφανίσεις:  23 
Μέγεθος:  197,6 KB 
ID: 254919


    WAN_FTTH Interface
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  WAN_FTTH.jpg 
Εμφανίσεις:  19 
Μέγεθος:  189,5 KB 
ID: 254920


    Interface Assignments
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Assignments.png 
Εμφανίσεις:  14 
Μέγεθος:  31,5 KB 
ID: 254921


    Point-to-Point Devices
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Point-to-Point Devices.png 
Εμφανίσεις:  13 
Μέγεθος:  61,1 KB 
ID: 254922


    VLAN Interfaces
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  VLAN.png 
Εμφανίσεις:  13 
Μέγεθος:  35,9 KB 
ID: 254923


    System -> Log Files -> General
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Logs.jpg 
Εμφανίσεις:  15 
Μέγεθος:  323,6 KB 
ID: 254925



    Παράθεση Αρχικό μήνυμα από fadasma Εμφάνιση μηνυμάτων
    Στο opnsense, πήγαινε Interfaces > point to point > log file και δες αν υπάρχει κάποιο warning ή error.

    Επισης αν βάλεις το speedport απευθείας στο ONT χωρις το opnsense έχεις Ίντερνετ;

    Το σχετικό log file που αναφέρεις είναι κενό για κάποιο λόγο...

    Όταν συνδέω το speedport στο ONT ναι έχω κανονικά Ίντερνετ...


    Ένα σχετικό θέμα που βρήκα στο forum είναι αυτό:

    Παράθεση Αρχικό μήνυμα από panseit Εμφάνιση μηνυμάτων
    Καλησπέρα στην παρέα!

    Έχω κάποιες απορίες σχετικά με το OPNsense και το σετάρισμά του. Η τοπολογία του δικτύου μου ειναι/θα είναι η παρακάτω:



    Επίσης παραθέτω τις ρυθμίσεις μου έως τώρα.

    LAN


    WAN


    WAN_FTTH


    Assignments


    VLAN


    Unbound


    DNS over TLS


    Το πρόβλημα που αντιμετωπίζω είναι το εξής:

    1. 1. Δεν παίρνω public IPv6 address
    2. 2. Δε φαίνεται να λειτουργεί το DNS over TLS
    3. 3. Διάβασα στα Technical Specs που δημοσίευσε ο ΟΤΕ αυτό



      Να αλλάξω το VLAN priority στο WAN_FTTH ή δεν παίζει ρόλο;


    Τέλος κάποιες απορίες σχετικά με το VOIP.

    1. To 838 vlan id στην Cosmote είναι για το IPTV?
    2. To 839 vlan id στην Cosmote είναι για το VOIP?
    3. Αν το 839 είναι για το VOIP μπορώ να συνδέσω το Grandstream HT801 στο switch όπως το έχω στο αρχικό σχήμα και να κάνω την κλήση από εκεί μέσω αυτού του VLAN?
    4. Για να παίξει η τηλεφωνία αφού πάρω κωδικούς απλά σετάρω το HT801 και είμαι οκ; Χάνω κάποια βήματα;


    Σας ευχαριστώ!
    Attached Thumbnails Attached Thumbnails Logs.jpg  

    Τελευταία επεξεργασία από το μέλος user674386291 : 24-03-24 στις 23:26.

  5. #5
    Εγγραφή
    09-09-2011
    Περιοχή
    skg
    Μηνύματα
    3.120
    Downloads
    1
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    360/360 Mbps
    ISP
    HCN
    Router
    MikroTik hAP ac²
    Αν και πιθανώς δεν φταίει το παρακάτω, το θεωρώ λάθος επιλογή, μιας και υπάρχει πάντα το ενδεχόμενο να πάρεις CG-NAT IP στο WAN interface.

    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Block_private.png 
Εμφανίσεις:  30 
Μέγεθος:  21,9 KB 
ID: 254926

  6. #6
    Εγγραφή
    14-02-2003
    Περιοχή
    Θεσσαλονίκη
    Μηνύματα
    1.222
    Downloads
    19
    Uploads
    0
    ISP
    -
    Σαν αρχικό βήμα, νομίζω ότι πρέπει να ελεγχθεί στο Interface->overview αν το pppoe interface έχει πάρει IP.
    Αν δεν πήρε, το επόμενο βήμα είναι ο έλεγχος του σχετικό log file (Interfaces->Point-to-Point->Log file) μήπως υπάρχει κάτι χρήσιμο εκεί μέσα. Σημείωση: Προσοχή στο φίλτρο ανάλογα με το level πάνω δεξιά.

    Προσωπικά πάντως, νομίζω ότι σαν WAN θα έβαζα το pppoe connection, (φυσικά υπάρχουν κι άλλοι τρόποι να παίξει αυτό, απλώς το αναφέρω μήπως και λείπει κάποιο σχετικό setting).

  7. #7
    Εγγραφή
    11-03-2024
    Μηνύματα
    5
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    Παράθεση Αρχικό μήνυμα από x_undefined Εμφάνιση μηνυμάτων
    Αν και πιθανώς δεν φταίει το παρακάτω, το θεωρώ λάθος επιλογή, μιας και υπάρχει πάντα το ενδεχόμενο να πάρεις CG-NAT IP στο WAN interface.
    Το διόρθωσα αλλά όπως είπες δυστυχώς δεν έφτεγε αυτό...

    Παράθεση Αρχικό μήνυμα από thama Εμφάνιση μηνυμάτων
    Σαν αρχικό βήμα, νομίζω ότι πρέπει να ελεγχθεί στο Interface->overview αν το pppoe interface έχει πάρει IP.
    Αν δεν πήρε, το επόμενο βήμα είναι ο έλεγχος του σχετικό log file (Interfaces->Point-to-Point->Log file) μήπως υπάρχει κάτι χρήσιμο εκεί μέσα. Σημείωση: Προσοχή στο φίλτρο ανάλογα με το level πάνω δεξιά.

    Προσωπικά πάντως, νομίζω ότι σαν WAN θα έβαζα το pppoe connection, (φυσικά υπάρχουν κι άλλοι τρόποι να παίξει αυτό, απλώς το αναφέρω μήπως και λείπει κάποιο σχετικό setting).
    Σχετικά με την πρώτη παρατήρηση, το pppoe interface έχει πάρει μία IPv6 link-local

    Interfaces -> Overview
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Interfaces - Overview.png 
Εμφανίσεις:  11 
Μέγεθος:  51,2 KB 
ID: 254927


    Σχετικά με τη δεύτερη, σε ευχαριστώ πολύ για την επισύμανση με το φίλτρο... Βρήκα το παρακάτω:

    Interfaces -> Point-to-Point -> Log file
    Spoiler:
    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Point-to-Point - Log File.png 
Εμφανίσεις:  9 
Μέγεθος:  142,1 KB 
ID: 254928


    Κάνει διαρκώς reconnection attempt...

  8. #8
    Εγγραφή
    12-06-2011
    Μηνύματα
    8.371
    Downloads
    4
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    500/50 + 250/80
    ISP
    Ote/Vodafone
    Router
    Pf plus/nokia - mu5001 5G
    Παράθεση Αρχικό μήνυμα από x_undefined Εμφάνιση μηνυμάτων
    Αν και πιθανώς δεν φταίει το παρακάτω, το θεωρώ λάθος επιλογή, μιας και υπάρχει πάντα το ενδεχόμενο να πάρεις CG-NAT IP στο WAN interface.

    Πατήστε στην εικόνα για να τη δείτε σε μεγέθυνση. 

Όνομα:  Block_private.png 
Εμφανίσεις:  30 
Μέγεθος:  21,9 KB 
ID: 254926
    Ειναι λανθασμενη η αποψη οτι αυτο επηρεαζει καπου το cgnat. Το οτι εχεις private ip δεν σημαινει οτι θα ΛΑΒΕΙΣ και κινηση απο prιvate ip's. Και ως γνωστον, μας ενδιαφερουν τα source ip's, το απο που περναει η κινηση δεν το ξερει κανενα firewall (θα επρεπε να κανει trace)
    H μονη περιπτωση ειναι το wan να συνδεεται και να επικοινωνει με private hosts, σε non Internet related περιπτωσεις.
    Ακομα και αυτα που λεει η opn ειναι βλακειες. Μπορειτε παντα να το δοκιμασετε.

    Επισης το να κρυβεις τις link local ip's ειναι τουλαχιστον αστειο. Το ιδιο και για τις mac addresses


    Απο κει και περα, κλεισε το ipv6 μιας και σε μπερδευει. Αυτα που βλεπεις ειναι παντελως ασχετα.

    Ομως κατι αλλο κακο συμβαινει. Η igb0 που ειναι η τοπικη ethernet γυριζει σε down. Γιατι? Δεν θα επρεπε.

    Κατι συμβαινει με τα καλωδια/switch σου. Ισως γιαυτο και δεν φτανει τιποτε στο bras.
    Πως ακριβως τα εχεις συνδεσει ολα αυτα?
    Τελευταία επεξεργασία από το μέλος netblues : 25-03-24 στις 09:29.

  9. #9
    Εγγραφή
    14-02-2003
    Περιοχή
    Θεσσαλονίκη
    Μηνύματα
    1.222
    Downloads
    19
    Uploads
    0
    ISP
    -
    Παράθεση Αρχικό μήνυμα από netblues Εμφάνιση μηνυμάτων
    Απο κει και περα, κλεισε το ipv6 μιας και σε μπερδευει. Αυτα που βλεπεις ειναι παντελως ασχετα
    Θα συμφωνήσω με την προτροπή του netblues. Η απενεργοποίηση του IPv6, (τουλάχιστον στα πρώτα βήματα) θα βοηθήσει να μειωθεί ο "θόρυβος" στα log files
    Επίσης, στα VLAN Interfaces για priority θα δοκίμαζα την επιλογή του 7 αντί για best effort.

  10. #10
    Εγγραφή
    12-06-2011
    Μηνύματα
    8.371
    Downloads
    4
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    500/50 + 250/80
    ISP
    Ote/Vodafone
    Router
    Pf plus/nokia - mu5001 5G
    Εφοσον μιλαμε για cosmote και δεν υπαρχουν αλλα vlan, priority 0, το default. Με τα υπολοιπα η συμπεριφορα ειναι αγνωστη.

  11. #11
    Εγγραφή
    09-09-2011
    Περιοχή
    skg
    Μηνύματα
    3.120
    Downloads
    1
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    360/360 Mbps
    ISP
    HCN
    Router
    MikroTik hAP ac²
    Παράθεση Αρχικό μήνυμα από netblues Εμφάνιση μηνυμάτων
    Ειναι λανθασμενη η αποψη οτι αυτο επηρεαζει καπου το cgnat. Το οτι εχεις private ip δεν σημαινει οτι θα ΛΑΒΕΙΣ και κινηση απο prιvate ip's. Και ως γνωστον, μας ενδιαφερουν τα source ip's, το απο που περναει η κινηση δεν το ξερει κανενα firewall (θα επρεπε να κανει trace)
    Έχω την εντύπωση ότι όταν είσαι σε CGNAT, το WAN interface έχει gateway με IP στο 100.64/10, οπότε ναι, θα λάβεις κίνηση από τέτοια IP. Γι' αυτό λέει να το ενεργοποιείς μόνο σε interfaces με public addresses.

    Βασικά όντως θα κοιτάει μόνο το source address στο πακέτο και όχι από πού έρχεται αυτό, οπότε πιστεύω έχεις δίκιο ότι δεν επηρεάζει και ότι λέει βλακείες. Θα μπορούσε γενικά ίσως να ενοχλεί σε περίπτωση που ο πάροχος έχει άλλες τέτοιες υπηρεσίες (π.χ. DNS servers) με private IPs, που η Cosmote δεν έχει.
    Τελευταία επεξεργασία από το μέλος x_undefined : 25-03-24 στις 12:58.

  12. #12
    Εγγραφή
    12-06-2011
    Μηνύματα
    8.371
    Downloads
    4
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    500/50 + 250/80
    ISP
    Ote/Vodafone
    Router
    Pf plus/nokia - mu5001 5G
    Ουτε και τοτε.
    Θα ειναι replies και περνανε.
    Το ping στο 10,χ gateway του cgnat το αποδεικνυει. Τουλαχιστον οι αντιγραφες να μην προσθετουν λαθος σαλτσες.

    Υγ λιγο που το ειδα, ερχονται κατι netbios brroadcasts σε cosmote απο 10 ρι δικτυο

  13. #13
    Εγγραφή
    11-03-2024
    Μηνύματα
    5
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    Καταρχάς σας ευχαριστώ πολύ όλους για την βοήθεια σας

    Κατά δεύτερον όπως μάλλον έχετε ήδη καταλάβει οι γνώσεις μου σε δίκτυα είναι περιορισμένες και κάθε βήμα το πάω ψάχνοντας και διαβάζοντας...

    Μέχρι τώρα προσπαθούσα να κάνω configure το opnsense τελείως απομονομένο από το δίκτυο (opnsense [WAN] -> laptop) και μετά έκανα τη σύνδεση με το ONT

    Έκανα restore τα settings του opnsense σε factory defaults και έχω κάνει την εξής συνδεσμολογία:

    Nokia ONT -> [WAN] opnsense [LAN] -> laptop

    Όταν χτυπάω 192.168.1.1, ενώ υποτίθεται πως θα έπρεπε να μου βγάζει το configuration portal, δεν βγάζει απολύτως τίποτα...

    Το laptop δεν παίρνει καν IP...

  14. #14
    Εγγραφή
    12-06-2011
    Μηνύματα
    8.371
    Downloads
    4
    Uploads
    0
    Τύπος
    FTTH
    Ταχύτητα
    500/50 + 250/80
    ISP
    Ote/Vodafone
    Router
    Pf plus/nokia - mu5001 5G
    Προφανως κατι γινεται με το hardware κομματι του δικτυου σου. Οσο δεν παιζει το lan τι να συζηταμε για τα υπολοιπα.

    Αληθεια, γιατι γενικοτερα ο κοσμος παει στις αντιγραφες? Γιατι opnsense και οχι το original? Γιατι issabel και οχι freepbx?

  15. #15
    Εγγραφή
    09-02-2006
    Μηνύματα
    3.072
    Downloads
    4
    Uploads
    0
    Τύπος
    VDSL2
    ISP
    ΟΤΕ Conn-x
    Router
    OPNsense
    Σου προτείνω να το στήσεις από την αρχή και το σημαντικότερο, να διαβάσεις το documentation που βρίσκεται εδώ: https://docs.opnsense.org/index.html
    Καλύτερα να ξοδέψεις 3 ώρες διαβάζοντας το documentation 10 λεπτά να στήσεις το firewall, παρά να ξοδέψεις 13 ώρες ψάχνοντας να βρες τι φταίει.

    Αφού λοιπόν διαβάσεις το documentation, θα συνδέσεις το router του με μια οθόνη ή τηλεόραση και θα στήσεις εκεί το LAN και το WAN (με vlan 835 και PPPoE).

Tags για αυτό το Θέμα

Bookmarks

Bookmarks

Δικαιώματα - Επιλογές

  • Δεν μπορείτε να δημοσιεύσετε νέα θέματα
  • Δεν μπορείτε να δημοσιεύσετε νέα μηνύματα
  • Δεν μπορείτε να αναρτήσετε συνημμένα
  • Δεν μπορείτε να επεξεργαστείτε τα μηνύματα σας
  •  
  • Τα BB code είναι σε λειτουργία
  • Τα Smilies είναι σε λειτουργία
  • Το [IMG] είναι σε λειτουργία
  • Το [VIDEO] είναι σε λειτουργία
  • Το HTML είναι εκτός λειτουργίας