Σελ. 91 από 92 ΠρώτηΠρώτη ... 71818689909192 ΤελευταίαΤελευταία
Εμφάνιση 1.351-1.365 από 1370
  1. #1351
    Εγγραφή
    10-06-2006
    Περιοχή
    Eastattica
    Μηνύματα
    167
    Downloads
    3
    Uploads
    0
    Τύπος
    VDSL2
    Ταχύτητα
    54999/5503 kBit/s
    ISP
    Cosmote, AWMN
    Router
    RB4011iGS+5HacQ2HnD
    Path Level
    Interleaved
    Με λίγο clopy/paste από τα δικά σας rule, κουτσοκατάφερα αυτό που ήθελα!

    Φυσικά αν έχετε να προτείνετε κάτι καλύτερο εννοείτε το διορθώνετε!!

    Κώδικας:
    ip firewall mangle
    
    add action=mark-connection chain=forward comment=____Speedtest connection-state=new dst-address-list=speedtest.net dst-port=443,8080 new-connection-mark=speedtest out-interface=ether1 \
        passthrough=yes protocol=tcp
    add action=mark-packet chain=forward connection-mark=speedtest new-packet-mark=speedtest passthrough=no
    Κώδικας:
    ip firewall filter
    
    add action=add-dst-to-address-list address-list=speedtest.net address-list-timeout=none-dynamic chain=forward comment="speedtest.com tracking" dst-port=8080,443 log=yes protocol=tcp tls-host=\
        www.speedtest.net

    Κώδικας:
    /queue simple
    
    add name=speedtest.net packet-marks=speedtest target=ether1

    Όσοι είστε με ppoe if κάνετε αντικατάσταση το ether1 ---> pppoe-out1

    Το simple queue το βάζετε πρώτο.

  2. #1352
    Εγγραφή
    01-11-2005
    Μηνύματα
    2.409
    Downloads
    41
    Uploads
    0
    Σε μια γραμμη 50/5 πως θα του πω να δινει 3.8Μbit για τα πρωτα 5ΜΒ upload και μετα να συνεχιζει στα 2.3Mbit ανα ip οπως το εχω?
    Αντιστοιχα θα κανω το ιδιο και στο κατεβασμα για τα πρωτα 50ΜΒ να δινει 41Μbit.

    /queue type add kind=pcq name=pcq-upload-custom pcq-classifier=src-address pcq-rate=2300k

    /queue type add kind=pcq name=pcq-download-custom pcq-classifier=dst-address pcq-rate=27M

    /queue simple add name=Throttle-Each queue=pcq-upload-custom/pcq-download-custom target=192.168.89.0/24,192.168.88.0/24

  3. #1353
    Εγγραφή
    01-11-2005
    Μηνύματα
    2.409
    Downloads
    41
    Uploads
    0
    έχει γραφτεί παρα πισω απάντηση να το ψάξω?

  4. #1354
    Εγγραφή
    28-03-2006
    Περιοχή
    Salonica City
    Ηλικία
    45
    Μηνύματα
    29.810
    Downloads
    23
    Uploads
    0
    Τύπος
    VDSL2
    Ταχύτητα
    110/11
    ISP
    Cosmote
    DSLAM
    ΟΤΕ - ΕΡΜΟΥ
    Router
    RB4011iGS+5 Modem:VMG1312
    Path Level
    Interleaved
    Αν θυμάμαι καλά... το ρώτησες και σε άλλο σημείο.
    :~$
    "Anyone can build a fast CPU.
    The trick is to build a fast system."

    Seymour Cray...

  5. #1355
    Εγγραφή
    01-11-2005
    Μηνύματα
    2.409
    Downloads
    41
    Uploads
    0
    ναι αλλά μου ειπαν να ρωτήσω εδω

  6. #1356
    Εγγραφή
    03-09-2011
    Μηνύματα
    1.943
    Downloads
    8
    Uploads
    0
    ISP
    Vodafone
    Router
    CRS 109/RB2011/RB-951G
    Path Level
    Interleaved
    Η δυσκολια σε αυτο ειναι πως θα του πεις να ξεκιναει ετσι και να σταματαει μετα σε καποιο BW.
    Φάγαμε...... πακέτο

  7. #1357
    Εγγραφή
    01-11-2005
    Μηνύματα
    2.409
    Downloads
    41
    Uploads
    0
    νόμιζα οτι είναι απλό και οτι εχει απαντηθεί.
    θα κοιτάξω και αλλου τότε κάποια στιγμή.

    δηλαδή μόνο το να ξεκινάει με full bandwidth και να το κόβει μετά από κάποιον όγκο γίνεται εύκολα μεσα απο το winbox?

  8. #1358
    Εγγραφή
    14-05-2004
    Περιοχή
    GR/Crete
    Ηλικία
    34
    Μηνύματα
    4.979
    Downloads
    25
    Uploads
    0
    Ταχύτητα
    24576/1024
    ISP
    OTEnet
    Router
    Siemens κάτι
    SNR / Attn
    9,1(dB) / 28(dB)
    Path Level
    Fastpath
    Παράθεση Αρχικό μήνυμα από kostas2005 Εμφάνιση μηνυμάτων
    Σε μια γραμμη 50/5 πως θα του πω να δινει 3.8Μbit για τα πρωτα 5ΜΒ upload και μετα να συνεχιζει στα 2.3Mbit ανα ip οπως το εχω?
    Αντιστοιχα θα κανω το ιδιο και στο κατεβασμα για τα πρωτα 50ΜΒ να δινει 41Μbit.

    Κώδικας:
    add action=mark-connection chain=forward comment="---Mark TCP 80,443 connections" connection-mark=no-mark connection-state=new dst-port=80,443 \
        new-connection-mark=HTTP out-interface=all-ppp passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment="---Mark TCP 80,443 up to 2.5Mbytes QOS_3" connection-bytes=0-2500000 connection-mark=HTTP new-packet-mark=QOS_3 \
        passthrough=no protocol=tcp
    add action=mark-packet chain=forward comment="---Mark TCP 80,443  2.5Mbytes and up  QOS_6" connection-bytes=2500001-0 connection-mark=HTTP new-packet-mark=QOS_6 \
        passthrough=no protocol=tcp
    αυτό είναι το δικό μου
    προσάρμοσε το
    It's a wonderful life! www.incrediblecrete.gr
    Άπο τα πιο αντικειμενικά ενημερωτικά site με πολύ αξιόπιστη έρευνα/ρεπορτάζ ThePressProject
    Must see! Google: Το μεγάλο μας τσίρκο

  9. #1359
    Εγγραφή
    03-09-2011
    Μηνύματα
    1.943
    Downloads
    8
    Uploads
    0
    ISP
    Vodafone
    Router
    CRS 109/RB2011/RB-951G
    Path Level
    Interleaved
    Mε connection rate δοκιμασε εσυ kostas2005.
    Φάγαμε...... πακέτο

  10. #1360
    Εγγραφή
    01-11-2005
    Μηνύματα
    2.409
    Downloads
    41
    Uploads
    0
    ευχαριστώ παιδιά.
    μου εξηγείται τι ακριβώς να κάνω με λόγια?
    theodor δηλαδη να φτιάξω 4 ουρές, 2 για up και 2 για down και αντι για 80 και 443 να συμπεριλάβω τα πάντα?
    η μηπως ανεξάρτητα απο up η down οταν καποιος ξεπεράσει εναν συγκεκριμένο όγκο παντου να τον ρίχνει σε ουρα?
    macro τι εννοείς?

  11. #1361
    Εγγραφή
    03-09-2011
    Μηνύματα
    1.943
    Downloads
    8
    Uploads
    0
    ISP
    Vodafone
    Router
    CRS 109/RB2011/RB-951G
    Path Level
    Interleaved
    Αν δεις αυτο που σου ποσταρε ο theodor γραφει connection bytes................ εγω καποια στιγμη ειχα δοκιμασει με connection rate και δουλευε καλα. Με bytes δε νομιζω οτι μπορεις να το επιτυχεις μιας και κανει αλλο πραγμα.
    Φάγαμε...... πακέτο

  12. #1362
    Εγγραφή
    14-05-2004
    Περιοχή
    GR/Crete
    Ηλικία
    34
    Μηνύματα
    4.979
    Downloads
    25
    Uploads
    0
    Ταχύτητα
    24576/1024
    ISP
    OTEnet
    Router
    Siemens κάτι
    SNR / Attn
    9,1(dB) / 28(dB)
    Path Level
    Fastpath
    άλλο το ένα και άλλο το άλλο
    μπορείς να βάλεις και συνδυασμό ώστε να μήν πιάνει streaming αρχεία (netflix, youtube κλπ)
    με bytes σκέτο κάποια στιγμή θα πιάσει και e-radio

    ανάλογα τι θές να κάνεις

    με rate σκέτο θα πιάνει τα πάντα και είναι περιττό γιατί υπάρχει το burst που κάνει την ίδια δουλειά εκτός αν θές να βάλεις περιορισμούς σε ip/ports κλπ
    It's a wonderful life! www.incrediblecrete.gr
    Άπο τα πιο αντικειμενικά ενημερωτικά site με πολύ αξιόπιστη έρευνα/ρεπορτάζ ThePressProject
    Must see! Google: Το μεγάλο μας τσίρκο

  13. #1363
    Εγγραφή
    01-11-2005
    Μηνύματα
    2.409
    Downloads
    41
    Uploads
    0
    μαλλον θελω το burst στην δικια μου περίπτωση.
    μπορώ να δηλώσω με burst αυτό που περιγράφω παραπάνω ?

  14. #1364
    Εγγραφή
    10-06-2006
    Περιοχή
    Eastattica
    Μηνύματα
    167
    Downloads
    3
    Uploads
    0
    Τύπος
    VDSL2
    Ταχύτητα
    54999/5503 kBit/s
    ISP
    Cosmote, AWMN
    Router
    RB4011iGS+5HacQ2HnD
    Path Level
    Interleaved
    Παιδιά μία βοήθεια,

    Προσπαθώ εδώ και καιρό να βρώ κάποιον τρόπο να περιορίσω το bandwidth των Windows Update.

    Μέσω regex, κάνω match source IP Address (δυναμική λίστα για 25μέρες), έπειτα mangle rule και τέλος simple queue.

    Την dynamic list την δημιουργώ, ώστε με άλλο rule να κάνω drop τα connections, όταν λειτουργεί απο 4G.

    Κώδικας:
    /ip firewall layer7-protocol
    add name=MicrosoftUpdates regexp="^.+(update.microsoft|windowsupdate|download.microsoft|wustat|wsus|sls.update.microsoft|vortex-win.data.microsoft.com|fe2.update.microsoft.com.akadns.net|vortex.data.microsoft|dl.delivery.mp|statsfe2.update.microsoft.com.akadns.net|ntservicepack).*$"
    
    /ip firewall mangle
    add action=mark-connection chain=forward comment="ms list dst Address List" connection-state=established,related,new new-connection-mark=ms-list1 passthrough=yes src-address-list=Windows_Update
    add action=mark-packet chain=forward connection-mark=ms-list1 connection-state=established,related,new new-packet-mark=ms passthrough=no
    
    
    /ip firewall filter
    add action=add-src-to-address-list address-list=Windows_Update address-list-timeout=3w4d chain=forward comment="Windows Update tracking" in-interface-list=WAN layer7-protocol=MicrosoftUpdates protocol=tcp src-port=80,443
    
    /queue simple
    add limit-at=3M/250k max-limit=10M/750k name=MS packet-marks=ms queue=pcq-upload-default/pcq-download-default target=pppoe-out1
    Ένα άλλο τρόπο που προσπάθησα χωρίς επιτυχία είναι να διαβάζω απο την cache του dns, αλλά το αποτέλεσμα το ίδιο.

    Κώδικας:
    /system scheduler
    add interval=2m name=microsoft on-event=":foreach i in=[/ip dns cache all find where (name~\"update.microsoft\" ||  name~\"windowsupdate\" ||  name~\"\
        download.microsoft\" ||  name~\"wustat\" ||  name~\"download.windowsupdate\" ||   name~\"ntservicepack\") && (type=\"A\") ] do={\r\
        \n     :local tmpAddress [/ip dns cache get \$i address];\r\
        \ndelay delay-time=10ms\r\
        \n#prevent script from using all cpu time\r\
        \n    :if ( [/ip firewall address-list find where address=\$tmpAddress] = \"\") do={         \r\
        \n     :local cacheName [/ip dns cache get \$i name] ;\r\
        \n     :log info (\"added entry: \$cacheName  \$tmpAddress\");\r\
        \n     /ip firewall address-list add address=\$tmpAddress list=MS timeout=23:59:59 comment=\$cacheName;\r\
        \n\r\
        \n}\r\
        \n\r\
        \n}" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/2016 start-time=00:01:00
        
    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="ms list dst" dst-address-list=MS new-packet-mark=ms passthrough=no
    add action=mark-packet chain=prerouting comment="ms list src" new-packet-mark=ms passthrough=no src-address-list=MS
    
    
    /queue simple
    add max-limit=1M/1M name=MS packet-marks=ms target=ether1-WAN time=6h-23h59m59s,sun,mon,tue,wed,thu,fri,sat
    Κάθε βοήθεια ευπρόσδεκτη

  15. #1365
    Εγγραφή
    28-03-2006
    Περιοχή
    Salonica City
    Ηλικία
    45
    Μηνύματα
    29.810
    Downloads
    23
    Uploads
    0
    Τύπος
    VDSL2
    Ταχύτητα
    110/11
    ISP
    Cosmote
    DSLAM
    ΟΤΕ - ΕΡΜΟΥ
    Router
    RB4011iGS+5 Modem:VMG1312
    Path Level
    Interleaved
    Παράθεση Αρχικό μήνυμα από RpMz Εμφάνιση μηνυμάτων
    Παιδιά μία βοήθεια,

    Προσπαθώ εδώ και καιρό να βρώ κάποιον τρόπο να περιορίσω το bandwidth των Windows Update.

    Μέσω regex, κάνω match source IP Address (δυναμική λίστα για 25μέρες), έπειτα mangle rule και τέλος simple queue.

    Την dynamic list την δημιουργώ, ώστε με άλλο rule να κάνω drop τα connections, όταν λειτουργεί απο 4G.

    Κώδικας:
    /ip firewall layer7-protocol
    add name=MicrosoftUpdates regexp="^.+(update.microsoft|windowsupdate|download.microsoft|wustat|wsus|sls.update.microsoft|vortex-win.data.microsoft.com|fe2.update.microsoft.com.akadns.net|vortex.data.microsoft|dl.delivery.mp|statsfe2.update.microsoft.com.akadns.net|ntservicepack).*$"
    
    /ip firewall mangle
    add action=mark-connection chain=forward comment="ms list dst Address List" connection-state=established,related,new new-connection-mark=ms-list1 passthrough=yes src-address-list=Windows_Update
    add action=mark-packet chain=forward connection-mark=ms-list1 connection-state=established,related,new new-packet-mark=ms passthrough=no
    
    
    /ip firewall filter
    add action=add-src-to-address-list address-list=Windows_Update address-list-timeout=3w4d chain=forward comment="Windows Update tracking" in-interface-list=WAN layer7-protocol=MicrosoftUpdates protocol=tcp src-port=80,443
    
    /queue simple
    add limit-at=3M/250k max-limit=10M/750k name=MS packet-marks=ms queue=pcq-upload-default/pcq-download-default target=pppoe-out1
    Ένα άλλο τρόπο που προσπάθησα χωρίς επιτυχία είναι να διαβάζω απο την cache του dns, αλλά το αποτέλεσμα το ίδιο.

    Κώδικας:
    /system scheduler
    add interval=2m name=microsoft on-event=":foreach i in=[/ip dns cache all find where (name~\"update.microsoft\" ||  name~\"windowsupdate\" ||  name~\"\
        download.microsoft\" ||  name~\"wustat\" ||  name~\"download.windowsupdate\" ||   name~\"ntservicepack\") && (type=\"A\") ] do={\r\
        \n     :local tmpAddress [/ip dns cache get \$i address];\r\
        \ndelay delay-time=10ms\r\
        \n#prevent script from using all cpu time\r\
        \n    :if ( [/ip firewall address-list find where address=\$tmpAddress] = \"\") do={         \r\
        \n     :local cacheName [/ip dns cache get \$i name] ;\r\
        \n     :log info (\"added entry: \$cacheName  \$tmpAddress\");\r\
        \n     /ip firewall address-list add address=\$tmpAddress list=MS timeout=23:59:59 comment=\$cacheName;\r\
        \n\r\
        \n}\r\
        \n\r\
        \n}" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/2016 start-time=00:01:00
        
    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="ms list dst" dst-address-list=MS new-packet-mark=ms passthrough=no
    add action=mark-packet chain=prerouting comment="ms list src" new-packet-mark=ms passthrough=no src-address-list=MS
    
    
    /queue simple
    add max-limit=1M/1M name=MS packet-marks=ms target=ether1-WAN time=6h-23h59m59s,sun,mon,tue,wed,thu,fri,sat
    Κάθε βοήθεια ευπρόσδεκτη
    Αν σου έρχεται κίνηση από ν6 δεν μπορείς να την πιάσεις με regexp.
    :~$
    "Anyone can build a fast CPU.
    The trick is to build a fast system."

    Seymour Cray...

Σελ. 91 από 92 ΠρώτηΠρώτη ... 71818689909192 ΤελευταίαΤελευταία

Παρόμοια Θέματα

  1. Mikrotik IPv4/IPv6 firewall
    Από deniSun στο φόρουμ MikroTik ADSL modems, routers & routerBOARDs
    Μηνύματα: 1573
    Τελευταίο Μήνυμα: 13-05-20, 22:37
  2. Mikrotik IPv6 σε PPPoE client με modem σε bridge mode
    Από deniSun στο φόρουμ MikroTik ADSL modems, routers & routerBOARDs
    Μηνύματα: 99
    Τελευταίο Μήνυμα: 15-10-19, 16:35
  3. Μηνύματα: 493
    Τελευταίο Μήνυμα: 18-05-19, 17:35
  4. IPV6 + IPV4 SPEED TEST
    Από babis3g στο φόρουμ ADSL
    Μηνύματα: 7
    Τελευταίο Μήνυμα: 05-09-14, 18:00

Tags για αυτό το Θέμα

Bookmarks

Bookmarks

Δικαιώματα - Επιλογές

  • Δεν μπορείτε να δημοσιεύσετε νέα θέματα
  • Δεν μπορείτε να δημοσιεύσετε νέα μηνύματα
  • Δεν μπορείτε να αναρτήσετε συνημμένα
  • Δεν μπορείτε να επεξεργαστείτε τα μηνύματα σας
  •  
  • Τα BB code είναι σε λειτουργία
  • Τα Smilies είναι σε λειτουργία
  • Το [IMG] είναι σε λειτουργία
  • Το [VIDEO] είναι σε λειτουργία
  • Το HTML είναι εκτός λειτουργίας