Login Form
IPv6 Ready
Εμφάνιση 1-7 από 7
  1. #1
    Εγγραφή
    30-09-2015
    Ηλικία
    26
    Μηνύματα
    4
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    Question
    Hello,

    I have ADSL from OTE with ZTE H108NS modem and my own OpenWrt (14.07) based router. I have modem in Bridge mode and I would like to setup IPv6, but IPv6 in modem web interface says "Not connected" while IPv4 says "Connected". When I use modem in PPPoE mode (not as bridge), it gets IPv6 address without problem and this address is then passed to OpenWrt LAN interface - I have modem connected both LAN and WAN with two cables - WAN for PPPoE and LAN in order to access web interface of modem from LAN.

    I tried to use configuration from article (and comment) from following site, but I cannot get it working. Article is also quite old.
    http://ipv6.ote.gr/?page_id=522

    Can someone help me get it working?

    Thank you in advance.

  2. #2
    Εγγραφή
    06-12-2003
    Περιοχή
    Αθήνα, Βούλα
    Ηλικία
    30
    Μηνύματα
    2.815
    Downloads
    11
    Uploads
    1
    Τύπος
    VDSL2
    Ταχύτητα
    29999/2496
    ISP
    Conn-x OTE
    DSLAM
    ΟΤΕ - ΒΟΥΛΑ
    Router
    Asus DSL-N17U
    SNR / Attn
    30,8(dB) / 4,4(dB)
    Path Level
    Fastpath
    Παράθεση Αρχικό μήνυμα από Eskymák Εμφάνιση μηνυμάτων
    Hello,

    I have ADSL from OTE with ZTE H108NS modem and my own OpenWrt (14.07) based router. I have modem in Bridge mode and I would like to setup IPv6, but IPv6 in modem web interface says "Not connected" while IPv4 says "Connected". When I use modem in PPPoE mode (not as bridge), it gets IPv6 address without problem and this address is then passed to OpenWrt LAN interface - I have modem connected both LAN and WAN with two cables - WAN for PPPoE and LAN in order to access web interface of modem from LAN.

    I tried to use configuration from article (and comment) from following site, but I cannot get it working. Article is also quite old.
    http://ipv6.ote.gr/?page_id=522

    Can someone help me get it working?

    Thank you in advance.
    I also have a similar setup with you (Speedtouch 585i v6 with Openwrt 14.07) . A few days before i noticed the WAN interface of my Openwrt router having an IPv6 ip address, which never happened before. I did not make any change for that. Login at the Openwrt router with SSH and check that at the file /etc/config/network the wan interface has the setting option 'ipv6' '1' . If you make any change at that file with SSH, in order to be activated, you have either to give the command /etc/init.d/network restart or to reboot the Openwrt router. Also try to replace @otenet.gr at your wan username with @ipv6ote.gr . If you have again any problem write us again
    Τελευταία επεξεργασία από το μέλος dimangelid : 30-09-15 στις 17:33.

  3. #3
    Εγγραφή
    30-09-2015
    Ηλικία
    26
    Μηνύματα
    4
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    Hello,

    I already did what you say, it is part of the official guide from OTE and also in other guides. No progress. Any ideas? :-)

    /etc/config/network
    Κώδικας:
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'auto'
    
    config interface 'lan'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option dns '8.8.8.8 8.8.4.4'
    	option ipaddr '192.168.20.1'
    	option _orig_ifname 'eth0 eth1 wlan1'
    	option _orig_bridge 'true'
    	option ifname 'eth0 eth1 tap0'
    	option ip6assign '64'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 1 2 3 4 '
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '2'
    	option ports '5 6'
    
    config interface 'WAN'
    	option proto 'pppoe'
    	option ifname 'eth2'
    	option password '*****'
    	option ipv6 '1'
    	option mtu '1492'
    	option username '****@otenet.gr'
    #this makes no difference:
    #option username '****@ipv6ote.gr'

  4. #4
    Εγγραφή
    06-12-2003
    Περιοχή
    Αθήνα, Βούλα
    Ηλικία
    30
    Μηνύματα
    2.815
    Downloads
    11
    Uploads
    1
    Τύπος
    VDSL2
    Ταχύτητα
    29999/2496
    ISP
    Conn-x OTE
    DSLAM
    ΟΤΕ - ΒΟΥΛΑ
    Router
    Asus DSL-N17U
    SNR / Attn
    30,8(dB) / 4,4(dB)
    Path Level
    Fastpath
    Παράθεση Αρχικό μήνυμα από Eskymák Εμφάνιση μηνυμάτων
    Hello,

    I already did what you say, it is part of the official guide from OTE and also in other guides. No progress. Any ideas? :-)

    /etc/config/network
    Κώδικας:
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'auto'
    
    config interface 'lan'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option dns '8.8.8.8 8.8.4.4'
    	option ipaddr '192.168.20.1'
    	option _orig_ifname 'eth0 eth1 wlan1'
    	option _orig_bridge 'true'
    	option ifname 'eth0 eth1 tap0'
    	option ip6assign '64'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 1 2 3 4 '
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '2'
    	option ports '5 6'
    
    config interface 'WAN'
    	option proto 'pppoe'
    	option ifname 'eth2'
    	option password '*****'
    	option ipv6 '1'
    	option mtu '1492'
    	option username '****@otenet.gr'
    #this makes no difference:
    #option username '****@ipv6ote.gr'
    I have no further ideas, as i have deactivated ipv6 on my Openwrt router. I suggest you flash your router with the latest available Openwrt version and try again. Also i made a mistake at my first message, my router also has OpenWRT 14.07 (build 10530) . If you have no results with the update inform us and wait 1-2 days in order to see if someone else knows what it happens. Otherwise you can call OTE at 13888 and tell them what happens.

  5. #5
    Εγγραφή
    30-09-2015
    Ηλικία
    26
    Μηνύματα
    4
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    So I decided to completely reflash my router and restore factory settings. After that, IPv6 started working as it should, just with "option ipv6 '1". :-)

    In modem interface, I still can see under IPv6:
    Status:Not Connected
    Who cares, there are more options there, which probably doesnt work and have on effect in Bridge mode...

    It will take few days to configure everything again, because I want to avoid of importing backup. I am actually very happy with this solution, much better than fight with issue in modem or at OTE side... :-)

    Thanks

  6. #6
    Εγγραφή
    06-12-2003
    Περιοχή
    Αθήνα, Βούλα
    Ηλικία
    30
    Μηνύματα
    2.815
    Downloads
    11
    Uploads
    1
    Τύπος
    VDSL2
    Ταχύτητα
    29999/2496
    ISP
    Conn-x OTE
    DSLAM
    ΟΤΕ - ΒΟΥΛΑ
    Router
    Asus DSL-N17U
    SNR / Attn
    30,8(dB) / 4,4(dB)
    Path Level
    Fastpath
    .
    Παράθεση Αρχικό μήνυμα από Eskymák Εμφάνιση μηνυμάτων
    So I decided to completely reflash my router and restore factory settings. After that, IPv6 started working as it should, just with "option ipv6 '1". :-)

    In modem interface, I still can see under IPv6:
    Status:Not Connected
    Who cares, there are more options there, which probably doesnt work and have on effect in Bridge mode...

    It will take few days to configure everything again, because I want to avoid of importing backup. I am actually very happy with this solution, much better than fight with issue in modem or at OTE side... :-)

    Thanks
    Did you just reset to OpenWRT defaults or flashed 15.05 and reset? In any case i'm glad that you solved your problem Don't care about what the ZTE says at its menu, you are in bridge mode and the ZTE just handles the ADSL synchronisation, nothing else. All the other stuff (including IPv6) are handled by your OpenWRT router! In my case my modem (good old Speedtouch 585i v6) does not support IPv6 at all. But i can get an IPv6 address if i remove option 'ipv6' '0'

  7. #7
    Εγγραφή
    30-09-2015
    Ηλικία
    26
    Μηνύματα
    4
    Downloads
    0
    Uploads
    0
    ISP
    ΟΤΕ Conn-x
    I reflashed whole system to the latest availiable version for my device, which is same as before, thanks to automatic updates. I had more reasons to do that, like changing file system from JFFS2 to UBIFS, updating recovery system and so. Part of this process was factory reset which maybe would solved issues itself.

    Basically I just entered PPPoE credentials and it got IPv6 working.

    Someone could find configuration helpfull.

    /etc/config/network
    Κώδικας:
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix ****:****:****::/48'
    
    config interface 'lan'
    	option ifname 'eth0 eth1'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    	option ipaddr '192.168.20.1'
    
    config interface 'wan'
    	option ifname 'eth2'
    	option proto 'pppoe'
    	option username '*****@otenet.gr'
    	option password '******'
    	option ipv6 '1'
    
    config interface 'wan6'
    	option ifname '@wan'
    	option proto 'dhcpv6'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 1 2 3 4 '
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '2'
    	option ports '5 6'
    /etc/config/dhcp
    Κώδικας:
    config dnsmasq
    	option domainneeded '1'
    	option boguspriv '1'
    	option filterwin2k '0'
    	option localise_queries '1'
    	option rebind_protection '1'
    	option rebind_localhost '1'
    	option local '/lan/'
    	option domain 'lan'
    	option expandhosts '1'
    	option nonegcache '0'
    	option authoritative '1'
    	option readethers '1'
    	option leasefile '/tmp/dhcp.leases'
    	option resolvfile '/tmp/resolv.conf.auto'
    	option port '0'
    
    config dhcp 'lan'
    	option interface 'lan'
    	option start '100'
    	option limit '150'
    	option leasetime '12h'
    	option dhcpv6 'server'
    	option ra 'server'
    	option ignore '0'
    	list dhcp_option '6,192.168.20.1'
    
    config dhcp 'wan'
    	option interface 'wan'
    	option ignore '1'
    
    config odhcpd 'odhcpd'
    	option maindhcp '0'
    	option leasefile '/tmp/hosts/odhcpd'
    	option leasetrigger '/usr/sbin/odhcpd-update'

Παρόμοια Θέματα

  1. Επιτέλους Bridge mode σε ZTE ZXHN H168N
    Από iliteo στο φόρουμ Vodafone VDSL
    Μηνύματα: 117
    Τελευταίο Μήνυμα: 25-05-17, 14:50
  2. Mikrotik IPv6 σε PPPoE client με modem σε bridge mode
    Από deniSun στο φόρουμ MikroTik ADSL modems, routers & routerBOARDs
    Μηνύματα: 58
    Τελευταίο Μήνυμα: 05-05-17, 14:30
  3. ZTE ZXV10 H201L(bridge mode) + tp-link wd741
    Από KeyMaKeR στο φόρουμ Cyta
    Μηνύματα: 4
    Τελευταίο Μήνυμα: 04-04-15, 02:40
  4. ZTE ZXV10 H201L bridge mode
    Από manospcistas στο φόρουμ Cyta
    Μηνύματα: 1
    Τελευταίο Μήνυμα: 13-11-14, 14:18

Tags για αυτό το Θέμα

Bookmarks

Bookmarks

Δικαιώματα - Επιλογές

  • Δεν μπορείτε να δημοσιεύσετε νέα θέματα
  • Δεν μπορείτε να δημοσιεύσετε νέα μηνύματα
  • Δεν μπορείτε να αναρτήσετε συνημμένα
  • Δεν μπορείτε να επεξεργαστείτε τα μηνύματα σας
  •  
  • Τα BB code είναι σε λειτουργία
  • Τα Smilies είναι σε λειτουργία
  • Το [IMG] είναι σε λειτουργία
  • Το [VIDEO] είναι σε λειτουργία
  • Το HTML είναι εκτός λειτουργίας